[PlanetCCRMA] muse segfault

Tracey Anne Hytry shakti@bayarea.net
Sun Dec 21 04:55:02 2003

On Sun, 21 Dec 2003 15:12:26 +0400
Guy Clotilde <guy.clotilde@wanadoo.fr> wrote:

> now muse segfaults when I launch it. It gives:
> cannot set tick on /dev/rtc: Permission non accordée (="not authorized")
> precise timer not available
> and strangely now timidity isn't accurate at all when I launch it non-root. 
> It seems to be a permission problem. Should I chmod /dev/rtc or is there another thing to do?

Yes, same here with the newest version.

I had to do what you suspected; change the permisions of /dev/rtc.  Changing group, etc didn't seem to do much.

Also, I had to intitially run it as "/usr/bin/muse -d" and had to set the Midi Sync to slave since I was using Jack(via qjackctl).  It seemed to find that I was using jack, but I went through and set things up while running in the "muse -d" mode first.

After that it seemed to come up fine from the desktop menus(no -R switch(no command line switches at all)) and a qick real time recording from our midi keyboards produced a decent .mid file on export, along with some ok printed sheet music of what we played.  There was a little glitch the first time that I tried to run it normally after the setup save from above, but that may have been from me having more windows and terms open on my desktop then I could keep track of.  After that it worked great.

Muse seems to be coming along very well, but I'm waiting for it to let me record the audio from the external synths while recording the midi input stream from the keyboards.  It's got some real nice midi clocking(we have an older MOTU midi time piece/8x8 midi switcher connected to the synths and the computer) which muse seems to be seeing.

I hope that helps, Tracey.