[PlanetCCRMA] Re: [CM] no sound with latest kernels/alsa modules

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu Dec 11 17:59:01 2003

> > Looks like you have the proper packages (latest alsa and kernel). I
> > don't know where to go from here, looks like you have already tried
> > tweaking all the controls in alsamixer (or gamix if you want a GUI),
> > which is what I would suggest. 
> I wanted to rebuild the alsa and alsa-kernel packages, to see if that
> would help.

The most recent ones? Probably not. 

> I did an "apt-get source alsa-driver" and then tried
> "rpmbuild --rebuild" on that, and then tried to install the resulting
> alsa-kernel package; I got this:
> # rpm -ivh alsa-kernel-2.4.23-1.ll.rhfc1.ccrma-1.0.0-1.rc1.cvs.i386.rpm
> error: Failed dependencies:
>         kernel-version-i386 = 2.4.23-1.ll.rhfc1.ccrma is needed by
> alsa-kernel-2.4.23-1.ll.rhfc1.ccrma-1.0.0-1.rc1.cvs

If you look in /usr/src/redhat/RPMS/* you will see that you have
packages in the i386, i586, i686 and athlon subdirectories. You have to
install the one that matches the architecture of the kernel you are
running (apt does that for you when you install planetccrma-core). 

This also applies if you try to download an older package and install
it, it has to match the architecture of your kernel (2.4.21, that is). 

> > You need to get the package with the architecture that matches your
> > kernel (probably i686 - 'rpm -q --qf "%{ARCH}\n" kernel_package' should
> > print it if you are not sure). 
> Maybe I am missing some package or have the wrong version.  When I tried
> that command you gave, I got:
> # rpm -q --qf "%{ARCH}\n" kernel_package
> package kernel_package is not installed

Sorry, I should have been more specific. I meant:
  rpm -q --qf "%{ARCH}\n" kernel-2.4.23-1.ll.rhfc1.ccrma
(for the latest version, uniprocessor kernel). That should print the
architecture of the kernel you specify. 

> So, do I need to do something special to be sure I have the right
> package?  Is there something in addition to "apt-get install
> planetccrma-core" that is required?

Not really. Proper configuration of /etc/modules.conf but you have that
fine, otherwise alsa would not even load. 

> > This may be a bug in ALSA itself, maybe you should post to the
> > alsa-devel list to see if somebody else is hitting the same problem. 
> Before I go to alsa-devel, do you know of anything else I can do to see
> if sound is being "sent" wherever it's supposed to go?  Can I look at
> something in /proc, for instance?  I tried ecasignalview, and it shows a
> meter moving as if there's sound when I play a wav file.  But, of
> course, no sound.

To me it sounds like something in the hardware is not being initialized
properly so everything looks like it works but, let's say, the output
amp is not "on". 

Do you remember the version number of the alsa package that was working? 
I must have it around somewhere and can try to get it for you. 
-- Fernando