[PlanetCCRMA] Re: [CM] no sound with latest kernels/alsa modules

Noel Bush noel@x-31.com
Thu Dec 11 17:36:02 2003

> > 1. Even if I do something goofy like "cat /dev/random > /dev/dsp", I
> > hear absolutely nothing.  This used to at least make a horrible noise.
> That would use OSS emulation. I take it you have tried to play a wav
> file using, for example, aplay (which uses the native ALSA interface). 

Yes, I've also tried playing a WAV file using aplay.  Prior to the point
when I uninstalled the alsa-kernel package for 2.4.21, I *was* able to
play a sound using aplay when I booted with the 2.4.21 kernel.

> Looks like you have the proper packages (latest alsa and kernel). I
> don't know where to go from here, looks like you have already tried
> tweaking all the controls in alsamixer (or gamix if you want a GUI),
> which is what I would suggest. 

I wanted to rebuild the alsa and alsa-kernel packages, to see if that
would help.  I did an "apt-get source alsa-driver" and then tried
"rpmbuild --rebuild" on that, and then tried to install the resulting
alsa-kernel package; I got this:

# rpm -ivh alsa-kernel-2.4.23-1.ll.rhfc1.ccrma-1.0.0-1.rc1.cvs.i386.rpm
error: Failed dependencies:
        kernel-version-i386 = 2.4.23-1.ll.rhfc1.ccrma is needed by

> You need to get the package with the architecture that matches your
> kernel (probably i686 - 'rpm -q --qf "%{ARCH}\n" kernel_package' should
> print it if you are not sure). 

Maybe I am missing some package or have the wrong version.  When I tried
that command you gave, I got:

# rpm -q --qf "%{ARCH}\n" kernel_package
package kernel_package is not installed

So, do I need to do something special to be sure I have the right
package?  Is there something in addition to "apt-get install
planetccrma-core" that is required?

> This may be a bug in ALSA itself, maybe you should post to the
> alsa-devel list to see if somebody else is hitting the same problem. 

Before I go to alsa-devel, do you know of anything else I can do to see
if sound is being "sent" wherever it's supposed to go?  Can I look at
something in /proc, for instance?  I tried ecasignalview, and it shows a
meter moving as if there's sound when I play a wav file.  But, of
course, no sound.