[PlanetCCRMA] Still stuck with Hammerfall HDSP.....

Ludo Max ludo.max@uconn.edu
Tue Dec 9 10:39:02 2003

There is good news and there is bad news....

The good news is that this card (yes, HDSP 9632) is working now.

The bad news is that I will have low self-esteem for the rest of my life due
to the way in which I messed this up. Luckily, there is a tiny little way (I
think) that I can blame Fernando too....  :)

Here is what happened (I am blushing already from embarrassment): Just a few
weeks ago I set this up as a tripple boot because of different software
requiring each of the three OS's: Win98, Win XP, Red Hat. RH was there
specifically to set up PlanetCCRMA and to try and compare low latency audio
work (probably in PD) on both WinXP and CCRMA. Anyway, all of these are just
excuses for not knowing much yet about either Linux or CCRMA. But I set it
up and it worked except for the HDSP. I tried to learn quickly from the list
and understood that I would need updated ALSA drivers. Then when Fernande
posted to the list last week that new versions of the Planet CCRMA kernels
and ALSA drivers were online, I literally followed all the steps to get them
installed. Turns out it was too literally: I copied and pasted what the
message said to add to /etc/apt/sources.list...... But, that line in his
message reads:
rpm http:///www-ccrma.stanford.edu/planetccrma/apt redhat/9/en/i386

So when I then did apt-get install planetccrma-core-redhat while also trying
to do other things at the same time, I didn't realize (and wasn't looking at
the screen telling me that some things could not be accessed) that
everything was checking for updates except for what I really needed....the
planetedge stuff. All because I had one too many /'s after the http.....

My biggest mistake of course was not realizing from the reboot that no new
kernel entry had been added to Grub and that dumb me was still booting into
the old kernel and drivers.

But yesterday, I removed one / from the "rpm...planetedge" line and then I
did get the new kernel and drivers. And now the card is working and I can
get to the real business of trying out PD for what we want to (which is
real-time band-reject filtering of speech with a low-enough latency to feed
it back into the speaker's ears as altered feedback; feel free to let me
know if you know of other software that we should consider instead of PD).

I guess all is good that ends good?

Thank you all for your time and my sincere excuses for wasting some of it by
not realizing that the new kernel and drivers were not installed until

Thanks again,