[PlanetCCRMA] planet-ccrma kernel 2.4.20-4.ll on redhat 9

shift8 shift8@speakeasy.net
Fri Apr 18 12:27:01 2003

hi josh!  

your rh 9 problem is related to your version of rpm.  you need to have
the version that built the package, most likely rpm-4.1-1.06 on a stock
rh 8.   i haven't really checked, but my guess the that the ccrma
apt-get repository is for 8.0/7.3 systems.  rh 9 is only like 2 weeks

martin - alsa is hard with any system ;)  on the kernel issue, you can't
just build an rpm of it had have it work like that.  the idea is that
you download the srpm, install it, run make config (or xconfig, or
menuconfig), change all of the kernel opts to match your hardware in the
/usr/src/linux-2.4.20-4.ll.acpi dir, then edit the .spec for the rpm (in
/usr/src/rehat/SPECS) to have the pre-install section copy your .config
generated from the above make to the source tree, then run rpmbuild... 

i know i've left out some steps, but that would be the general idea.  if
you really want to do this, you need to read the rpm-howtos, the
kernel-build howtos, etc....  

if your system is working with the downgraded ccrma kernel, you don't
have to do any of these things :)  you don't need to delete anything
ether (you should keep everything in /boot and /lib/modules in case you
ever need/want to boot the original 2.4.20-9)

my recommendation for both?  use 8.0 ;)  


On Fri, 2003-04-18 at 11:53, Josh Steiner wrote:
> hi martin, did you upgrade over a redhat 8 + planetccrma box? I havnt 
> figured out what i'm missing to get apt working on redhat 9 yet...
> -Josh
> Martin Dupras wrote:
> > Hi,
> >
> > I have upgraded my linux laptop about a week ago to redhat linux 9. It 
> > worked fine but I never could manage to get ALSA working.
> >
> > I downgraded my kernel to the planet-ccrma 2.4.20-4.ll.acpi kernel, 
> > and now things are pretty much all fine and groovy. But…
> >
> > I need to recompile a few things which need the kernel sources to be 
> > there. I got the kernel-2.4.20-4.ll.acpi.src.rpm. I followed the 
> > instructions on the planet-ccrma site but for some reason it will not 
> > build.
> >
> > I tried rpmbuild –ba kernel-2.4.20-4.ll.acpi.src.rpm, and that goes on 
> > compiling for maybe an hour, yet there are very many warnings (more 
> > than I would expect from recompiling a kernel), and the rpmbuild exits 
> > with errors, before creating an RPM or SRPM package. It does appear, 
> > however to create sources in /usr/src/linux-2.4.20-4.ll.acpi.
> >
> > I also checked that /usr/src/linux-2.4 is a link to 
> > /usr/src/linux-2.4.20-4.ll.acpi.
> >
> > Does anyone have any advice? I have a feeling that some things are 
> > left over from 2.4.20-9 that I had with the RH9 install, yet I don’t 
> > know where to look for them, and what obsolete files if any I can 
> > safely delete.
> >
> > Thanks!
> >
> > - martin
> >
> -- 
> ____________________________________________________
> independent u.s. drum'n'bass -- http://vitriolix.com
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma