[PlanetCCRMA] GPG-Pubkey Problem

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Nov 5 20:00:02 2002

> I happened upon your site tonight and was delighted.  I am currently 
> working on installing the rpms and then plan to install Ardour.  I 
> started following your step by step instructions for a Redhat 8.0 
> install.  The apt links on your site gave a Not Found error - URL not 
> found, so I went to freshrpms and downloaded the same apt rpm files. 

Oops, sorry, I'm in the middle of changing apt versions and I guess I
broke the links. Sorry again (and thanks for the report).

> That worked fine and I installed them on the system.  I then modified 
> the sources.list file and apt.conf files as you indicated. However, when 
> I tried to run apt-get update, I got an error message stating that there 
> were two or more versions of the package gpg-pubkey on my system.  Being 
> a relative Linux newbie, I can't figure out how to fix this problem. 

I'm just doing a full install of redhat 8.0 and I don't see any package
with that name in my machine. It must be something you installed
afterwards. Make sure your /etc/apt/sources.list is pointing only to the 
Planet CCRMA repository (for now). 

To see what you have that is named like that do a:
  rpm -q -a --last | grep gpg-pubkey

You should get a list of packages with that name (with the date on which
they were installed). Normally you should only have one (of each package)
and can erase the duplicated packages (with "rpm -e").  If for some reason
you need to have more than one of a given package you can tell apt to
ignore duplicate packages by editing /etc/apt/apt.conf and adding the
package that can be duplicated in the "Allowed-Duplicated" list. 

You may have installed more than one version of a package without knowing
it if you used "rpm -i" instead of "rpm -U" when installing a new version
of top of an older one.

-- Fernando