[PlanetCCRMA] jack - port segment key 0x0

Mark Knecht markknecht@attbi.com
Wed Dec 11 17:34:01 2002

Don't know what to make of this. With KDE running, when I run jackstart
I get 5 processes according to ps -aux. In this state alsaplayer will
not run.

If I drop out of KDE and run jackstart in a console, I get 7 processes.
I then go back into kde and alsaplayer runs fine.

Is this a jack error, or a system configuration problem?

Should I report this on the jack list?

On Wed, 2002-12-11 at 16:38, Mark Knecht wrote:
> Fernando,
>    This much was working last night. I couldn't play the CDs, but I
> could start the app. Today it's dead.
>    Has anyone on the Planet seen this error message before?
>    I tried removing both the jack and alsaplayer RPMs and reinstalling
> them. Still the same error.
>    It's a jack error - Ardour ran yesterday and has stopped working
> also...
> Thanks in advance,
> Mark
> [root@Godzilla root]# aplay -device="plughw" phone.wav
> [root@Godzilla root]# jackstart -R -d alsa -r 44100 -d hw &
> [1] 1389
> [root@Godzilla root]# jackd 0.41.0
> Copyright 2001-2002 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
> loading driver ..
> creating alsa driver ... hw|1024|2|44100|swmon
> [root@Godzilla root]# alsaplayer -r -o jack
> cannot determine shared memory segment for port segment key 0x0 (Invalid
> argument)
> jack: server not running?
> I could not find a suitable output module on your
> system. Make sure they're in "/usr/lib/alsaplayer/output/".
> Use the -o parameter to select one.
> failed to load output plugin (jack). exitting...
> [root@Godzilla root]#
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma