[CM] [OT] Fomus build problem

Dave Phillips dlphillips at woh.rr.com
Mon May 9 06:01:50 PDT 2016


I decided to update my Fomus installation. Things went well until here :

Making all in exe
make[3]: Entering directory '/home/dlphilp/src/fomus-code/src/exe'
depbase=`echo main.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
g++ -DHAVE_CONFIG_H -I. -I../..  -DNDEBUG -DNDEBUGOUT -pthread 
-I/usr/include -I../../src/lib/api -w -DNDEBUG -DNDEBUGOUT -O2 
-fomit-frame-pointer -O2 -MT main.o -MD -MP -MF $depbase.Tpo -c -o 
main.o main.cc &&\
mv -f $depbase.Tpo $depbase.Po
/bin/sh ../../libtool  --tag=CXX   --mode=link g++ -O2 
-fomit-frame-pointer -O2 -L/usr/lib64 -rpath /usr/local/lib  -o fomus 
main.o ../../src/lib/libfomus.la -lncursesw -lboost_program_options -ldl
libtool: link: g++ -O2 -fomit-frame-pointer -O2 -o .libs/fomus main.o  
-L/usr/lib64 ../../src/lib/.libs/libfomus.so -lltdl -lboost_system 
-lboost_filesystem -lboost_thread -lncursesw -lboost_program_options 
-ldl -Wl,-rpath -Wl,/usr/local/lib
../../src/lib/.libs/libfomus.so: undefined reference to 
collect2: error: ld returned 1 exit status
Makefile:440: recipe for target 'fomus' failed
make[3]: *** [fomus] Error 1
make[3]: Leaving directory '/home/dlphilp/src/fomus-code/src/exe'
Makefile:404: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/dlphilp/src/fomus-code/src'
Makefile:460: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/dlphilp/src/fomus-code'
Makefile:391: recipe for target 'all' failed
make: *** [all] Error 2

Can anyone tell me what's going on here ? I ran make clean, rebuilt, 
still the same error.

System here is Fedora 21, GCC 4.9.2.



More information about the Cmdist mailing list