[CM] Grace not running as user on Fedora 14

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Tue Mar 15 10:50:42 PDT 2011

On 03/15/2011 10:01 AM, Bill Sack wrote:
> the subject line pretty much says it ... i have a recent install of
> fedora 14 on a new thinkpad. installed the binary of Grace 3.7.1 and
> it will run as root but not in a user account.

Try installing the Planet CCRMA Grace package (if you have the Planet 
CCRMA repositories active):

   yum install cm-grace

and then run /usr/bin/Grace.
It does start here on fedora 14 as a normal user.

(most likely there is a missing library with the binary you downloaded, 
try an "ldd Grace" to see what is missing).

-- Fernando

> i tried old binaries
> too with the same result which leads me to think it's a fedora thing
> and not Grace.
> very odd: when i enter 'Grace' on the command line in my user account
> nothing is echoed back and no Grace terminal appears. the program
> seems to quit as soon as it starts, but reports no errors. i disabled
> SELinux (the security/watchdog in fedora) and tried again. but no
> difference. doing the same thing as root works fine, but i don't want
> to use the program as root.
> does anyone have any suggestions for how i can find out what the error is?
> thanks,
> Bill
> _______________________________________________
> Cmdist mailing list
> Cmdist at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/cmdist

More information about the Cmdist mailing list