[CM] hard times getting clm-4 working

Matti Koskinen mjkoskin at kolumbus.fi
Thu Jan 14 02:38:26 PST 2010

i can't get clm working ok under mac os x snow leopard. Adding -m32 to c-compile code and running aquamacs emacs slime, builds clm-4, but trying to compile e.g. singer.ins gives error. In clisp i get (loop-finish) outside loop error, and compilation ends. sbcl gives another error and prints inferior-lisp windows full of lisp code. 64-bit version of sbcl builds libclm.so, but loading stops, when lisp loads initmus.fasl. Compiling v.ins and jcrev.ins succeeds in 32-bit clisp and sbcl, and sound is getting from popi.clm and fmviolin.clm. Trying to compile clm under clozure cl either 64-bit or 32-bit gives error macroexpand-all is already defined in clozure cl. Then to continue inferior lisp dies with trace/bpt trap. Running clozure cl64.app works best. It doesn't give the bpt trap error and singer can be compiled. But then i tried the genetic_algs.lisp and spectr.ins i found from ccrma pages, compiles them after editing goal-spectr using open-input* and c-open-output-file. But running goal-spectr gives error and clozure cl debugger window is opened and it gives the error at foreign code at strlen+16. running goal-spectr under sbcl crashes equally. I think i tried commenting out clm-prints and it ran, but of course no output file was created.

same errors and problems under linux ubuntu karmic 32-bit.

and sometimes in osx sndplay doesn't stop, but keeps running taking 100 % of cpu.

help please.


More information about the Cmdist mailing list