[CM] Building Snd-FTH on Debian unstable...

Charles Turner vze26m98@optonline.net
Mon, 12 Mar 2007 18:25:28 -0400

Michael Scholz wrote on 3/11/07 at 11:57 PM

>> I configured with ./configure --with-gtk --with-jack --with-forth,
>> but Snd bailed in the link step because there was no -lfth on the
>> command line:
>You need a working fth in your $PATH, otherwise the configuration
>won't work.

I think I was a little fast and loose with the description of my
problem, or maybe I don't understand what you're saying.

In building Snd as Snd-FTH I ran configure, then make. During the final
link step, the linkers reported hundreds of unresolved references from
functions starting with the "fth_" prefix.

To fix this, I went to the Snd makefile and added the argument "-lfth"
because I asssumed that Snd would need to link to this library to find
the above unresolved references. The argument -lfth appeared to be
missing from the final link command as created by configure.

The re-build ("make") proceeded silently, indicating to me the
references had been resolved. I ran snd-fth and got a message that it
couldn't find libfth.0.so. I ran ldconfig against /usr/local/lib and
re-ran snd-fth and everything was OK then.

I'm pretty sure this is what happened, the whole build was a lot more
focussed than my initial OS X builds. :-)

Best, Charles