[CM] cm/clm in snd

thorne ego111@gmail.com
Tue, 11 Jul 2006 15:36:08 -0700


(I mistakenly sent this just to Bill Schottstaedt instead of the list
the first time.  Sorry.)

When i try `snd --display sibeol:0' (sibeol is my hostname) as a
regular user i get:

  ALSA lib pcm_dsnoop.c:556:(snd_pcm_dsnoop_open) unable to
  create IPC shm instance
  (snd:5507): Gtk-WARNING **: cannot open display: sibeol:0
  open pcm default for stream 1: Permission denied

and when i try as root i just get the

  (snd:5490): Gtk-WARNING **: cannot open display: sibeol:0

part.

I've tried locally from an xterm, from a tty session, from ssh
remotely and ssh from loopback.  Always the same.  Also tried
sibeol:0.0 and some various other randomness.

I'm thinking this is a config issue on my end, and i don't know
anything about X and display stuff; if anyone has any pointers for me
for what i need to read about i would be grateful.  Thanks.

On 7/2/06, Bill Schottstaedt <bil@ccrma.stanford.edu> wrote:
>
> > or at least to use it remotely by way of ssh? (I got
> > `Error: Cannot open display:' from my old version of snd otherwise).
>
> In the motif version, use the -d switch as in
>
> snd -d cat:0
>
> where "cat" is a known host name.  In gtk use --display with the
> same argument.  I run both versions across a local net (using
> ssh) all the time.
>
>


--