[CM] MidiShare error with CM

Dave Phillips dlphillips@woh.rr.com
Sun, 11 Dec 2005 19:20:53 -0500

Hi Rick:

  As you mentioned, there appear to be some problems with MidiShare.

  In the CMIO panel, if I select the Realtime tab and then click the 
Open button in the MidiShare tab, everything's a-okay. If I select the 
Score tab and click the MidiShare Open button, CM hangs and requires a 
manual kill.

  I tried the dictionary examples for MidiShare without using CMIO. The 
non-realtime example hung CM, just like using CMIO. The first realtime 
example worked okay. Example 3 sort of worked: It received MIDI input 
but reported this kind of error with each MIDI keypress :

Error in function NULLPTRP:
   Attempt to call (NULLPTRP #.(SYSTEM:INT-SAP #x080A94A4)) without 
Error flushed ...

  Example 4 didn't work but reported no errors.

  I ran Example 2 numerous times, it worked fine each time, so the 
realtime MidiShare output seems to be working.

  Tests were run on my laptop, I routed the CM output to the msAlsaSeq 
application in msConnect. The msAlsaSeq connection as routed to the 
internal soundchip on the laptop (OPL3 cheesewhiz). I also connected the 
output from a virtual MIDI keyboard to the msAlsaSeq bridge, that's how 
I tested Example 3.