[CM] error on snd startup

cristopher pierson ewing cewing@u.washington.edu
Tue, 22 Jun 2004 09:19:57 -0700 (PDT)


I'm still having the trouble with guile 1.4 vs. guile 1.6.4 this morning.
I have removed all directories and files associated with the intall of
guile 1.4 that I could find on the machine.  When I run compile i set
GUILE_CONFIG_path to /sw/bin, which is where the executable guile-config
lives (guile-config is a symbolic link to guile-1.6-config, which is what
fink created when it installed guile 1.6).  When the config process is
running, I see a line that says it is looking for guile, and then reports
'Guile 1.6.4' which is also what I get when I run 'guile-config
--version'.  After configuration i look in the makefile and the paths
given for the guile libs and flags are all pointing to /sw/lib and
/sw/bin and /sw/include, which seems right, as this is where guile 1.6
lives.  I run make clean and then make install and all the .c files
recompile.  The final result seems to have been successful.  I get an snd
command in /usr/local/bin, but when i try to run it, that same 'Syntax
error in fixed argument declaration' error shows up, and when I run 'snd
--version' it reports that the guile version being used is 1.4.

How can I get the snd configuration and make process to see the correct
guile installation?  Where is it even finding this guile 1.4?  There are
no more places where that installation lives on the machine.

Can anyone help with this?


Cris Ewing
CME and Telehealth Web Services
University of Washington
School of Medicine
Work Phone: (206) 685-9116
Home Phone: (206) 365-3413
E-mail: cewing@u.washington.edu

On Tue, 22 Jun 2004, Bill Schottstaedt wrote:

> If you're using a version of Snd that's more than a couple days
> old (I think you are), you need to
> make clean
> after you run configure.  In the current version, any change
> to config.h causes everything to be recompiled. I don't know
> if OSX has ldd -- maybe there's some equivalent -- in Linux,
> ldd snd
> will tell you what (shared?) libraries are being loaded.
> In Snd, (version) will report the Guile version, which
> should match the "help" info.
> I'll add some variable to handle the guile-1.6 business.
>  > trurl:~ cewing$ snd -l /usr/local/snd-7/fix-optargs.scm
>  > ERROR: Syntax error in fixed argument declaration.
> This could happen if your ~/.snd file uses define* -- try
> snd -noinit
> I think you can set the CFLAGS and LDFLAGS variables in the
> arguments to configure, rather than using setenv.
>  > ld: Undefined symbols:
>  > __XEditResGet16
> You must have defined HAVE_EDITRES.
> _______________________________________________
> Cmdist mailing list
> Cmdist@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/cmdist