[CM] SND-7 build errors on OSX

cristopher pierson ewing cewing@u.washington.edu
Mon, 21 Jun 2004 09:33:01 -0700 (PDT)

I just tried to hack config.h to show that I had motif installed.  I
edited makefile, giving the locations of libXm.a etc at the line
MOTIF-LIBS = blah, blah, blah.  Then I rewrote config.h to look like this:

#define USE_MOTIF 1
/* #undef USE_NO_GUI */
#define HAVE_MOTIF 1
#define HAVE_XmToolTipGetLabel 1
#define HAVE_XmCreateMultiList 1
#define HAVE_XmCreateDataField 1
#define HAVE_XmCreateButtonBox 1
#define HAVE_XmCreateTabStack 1
#define HAVE_XmCreateDropDown 1
#define HAVE_XmCreateColumn 1
#define HAVE_XmCreateFontSelector 1
#define HAVE_XmCreateColorSelector 1

Basically, all these lines are opposite of what they were originally.  But
when I run make again, the output, while different from before, still
hangs.  Here's the last bit from make:

gcc -c -DLOCALEDIR=\"/usr/local/share/locale\" -DHAVE_CONFIG_H  -I. -g -O2
-I/sw/include    snd-xxen.c
(cd po && make)
make[1]: Nothing to be done for `all'.
gcc  -I. -g -O2 headers.o audio.o io.o sound.o clm.o xen.o vct.o
sndlib2xen.o clm2xen.o midi.o snd-io.o snd-utils.o snd-listener.o
snd-error.o snd-completion.o snd-menu.o snd-axis.o snd-data.o snd-fft.o
snd-marks.o snd-file.o snd-edits.o snd-chn.o snd-dac.o snd-region.o
snd-select.o snd-find.o snd-snd.o snd-help.o snd-main.o snd-print.o
snd-trans.o snd-mix.o snd.o snd-env.o snd-xen.o snd-ladspa.o snd-rec.o
snd-kbd.o snd-sig.o snd-draw.o snd-run.o snd-xutils.o snd-xerror.o
snd-xhelp.o snd-xfind.o snd-xmenu.o snd-xdraw.o snd-xlistener.o snd-xchn.o
snd-xsnd.o snd-xregion.o snd-xdrop.o snd-xmain.o snd-xmix.o snd-xrec.o
snd-xenv.o snd-gxutils.o snd-gxbitmaps.o snd-gxcolormaps.o snd-xfft.o
snd-xprint.o snd-xfile.o snd-xxen.o  -o snd  -L/sw/lib -lguile
-lguile-ltdl -lm   -L/usr/X11R6/lib -lSM -lICE /sw/lib/libXm.a
/usr/X11R6/lib/libXp.a /usr/X11R6/lib/libXt.a -lXext -lXpm -lX11
-framework CoreAudio -framework CoreFoundation -framework CoreMIDI   -lm
ld: Undefined symbols:
make: *** [snd] Error 1
[trurl:/usr/local/snd-7] admin%

Are there more locations I need to hack, or am I missing some headers I
need to find?


Cris Ewing
CME and Telehealth Web Services
University of Washington
School of Medicine
Work Phone: (206) 685-9116
Home Phone: (206) 365-3413
E-mail: cewing@u.washington.edu

On Mon, 21 Jun 2004, Bill Schottstaedt wrote:

> Somehow your config.h is inconsistent -- I guess
> USE_MOTIF did not get set, so it's picking up the
> "no GUI" headers, but then for some reason the
> makefile is trying to include the Motif files.
> If configure didn't find Motif, you can give
> it the path with the --with-motif-prefix switch.