Tue, 4 Mar 2003 03:54:55 -0800
Michael Scholz has contributed more beautiful Ruby code:
contrib/popup.rb (translating popup.scm).
Also, as Michael pointed out to me, "redo" is already a
basic statement in Ruby (part of the loop control stuff),
so it collides with Snd's "redo" -- Snd's version (Ruby case)
is now named redo_edit; I added undo_edit, a synonym for undo,
for consistency, and added both names to the Scheme side
(as redo-edit and undo-edit).