[PlanetCCRMA] dual boot mess

Oded Ben-Tal obental at gmail.com
Fri Feb 18 10:04:46 PST 2022

I tried that version. When I run
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

I get some errors
Adding boot menu entry for UEFI Firmware Settings ...
error: ../grub-core/script/lexer.c:352:out of memory.
error: ../grub-core/script/lexer.c:352:syntax error.
error: ../grub-core/script/lexer.c:352:Incorrect command.
error: ../grub-core/script/lexer.c:352:syntax error.
Syntax error at line 226
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/efi/EFI/fedora/grub.cfg.new file attached.

On Fri, 18 Feb 2022 at 17:54, Donald Steven <t6sn7gt at aim.com> wrote:

> This is my grub entry for Windows using Ubuntu. Maybe it's of some help.
> menuentry '  Windows 10' --class windows --class os $menuentry_id_option
> 'osprober-chain-8CEECCD4EECCB82A' {
>     insmod part_msdos
>     insmod ntfs
>     set root='hd0,msdos1'
>     if [ x$feature_platform_search_hint = xy ]; then
>       search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos1
> --hint-efi=hd1,msdos1 --hint-baremetal=ahci1,msdos1 8CEECCD4EECCB82A
>     else
>       search --no-floppy --fs-uuid --set=root 8CEECCD4EECCB82A
>     fi
>     parttool ${root} hidden-
>     chainloader +1
> }
> ------ Original Message ------
> From: "Oded Ben-Tal" <obental at gmail.com>
> To: "Planet CCRMA list" <planetccrma at ccrma.stanford.edu>
> Sent: 2/18/2022 12:15:19 PM
> Subject: [PlanetCCRMA] dual boot mess
> Hello
> (and sorry for sending a not-audio-specific question but after much
> googling I'm lost for answers)
> I updated my computer to fedora 35 and managed to somehow mess up the boot
> option. When I try to boot into windows I get 2 grub errors
> - no such device for the UUID of the disk with windows on it
> -/EFI/Microsoft/Boot/bootmgfw.efi not found
> The windows partition is still there and the UUID is the correct one (this
> is copied from the fstab file I use to mount it on to fedora).
> I tried to solve the problem by adding
> menuentry 'Windows 10' {
>     search --fs-uuid --no-floppy --set=root B26A64746A64376F
>     chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
> }
> in /etc/grub.d/40.custom  file but obviously go the wrong variables in
> there...
> any help?
> thanks

Oded Ben-Tal
PI Datasounds, datasets and datasense <https://musicdatasense.org/> research
network (2022/23)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://cm-mail.stanford.edu/pipermail/planetccrma/attachments/20220218/b041d236/attachment.html>

More information about the PlanetCCRMA mailing list