[PlanetCCRMA] another nvidia driver problem

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Wed Mar 18 17:29:47 PDT 2015

On 03/14/2015 10:43 AM, Juan Reyes wrote:
> Hi Oded, Chris,
> Thanks for the tip Chris!.
> Are you guys able to compile akmod on RT Kernels?.

To run the nvidia binary drivers? Yes, I have done that in a couple of 
newly upgraded workstations as the NVidia cards I got are too new for 
the current nouveau (GTX750). Seems to run fine so far (running fc20 and 
3.14.29-200.rt26 - I have not tried fc21).

> BTW, It might compile but then when staring gdm will go on an infinite
> loop afaik. On 'telinit 3', trying to start 'X' manually, 'X' will
> complain about not finding the right LCD screen. Could not get how to
> hack this issue, -so frustrating and time consuming-.
> ...
> Just for the record, on the W540 I had to get rid of windoze EFI options
> because Fedora's EFI options are still kind of tricky

In installed and booted EFI (but on a new disk, I did not even try to 
make things dual boot).

>(may be I don't
> understand them well). Also because I was not able to load windoze
> partitions (not that I need them much). This meant ordering disks from
> Lenovo and starting from scratch.
> But if it's worth, as of now I am able to run the W540 with F-21 nouveau
> drivers using the bumblebee option without an nvidia binary on top. My
> understanding is that bumblebee allows the driver to access the nvidia
> side of the intel-nvidia graphics card. Not sure if akmod works with
> bumblebee.

I just tried bumblebee in my w540.

I followed the instructions here:

and only tried the option of running the nvidia binary driver (not 
nouveau). That seems to have worked. This was on a clean install of fc21 
from a usb key boot drive. And it only seems to have worked with the 
Fedora kernel (I had to reinstall bumblebee-nvidia to get the nvidia 
glue logic to rebuild on a new kernel). I tried on the rt kernel but 
that somehow did not work - but I did not try very hard, removing the rt 
kernel and rt-devel kernel packages got things working again. I have to 
see what the heck they are doing...

> I bet there are limitations using nouveau however, I am not getting lots
> of xruns while using jack and ffado.

I presume you mean you _are_ getting xruns, right?

I did not have time to do any audio testing yet on the new fc21 install 
with the binary driver. I just rebooted back into my working fc20 
install (I tried everything on a different hard disk so it is not easy 
to go back and forth).

> Honestly speaking, it would be great to have the RT Kernel with
> bumblebee and nvidia, just if anyone knows of a "how-to".

And let me know as well :-)

To get the original install going I used Chris's trick ("i915.modeset=1 
nouveau.modeset=0" in the kernel boot line).

The GPU seems to run hotter even with the binary driver. Running 
3.14.*-rt* is so far the best in terms of how hot the GPU feels (I can 
feel the area on the left of the trackpad getting hotter or cooler 
depending on what I run - I think that is where the GPU NVidia chipset 
is located). If I run 3.18.*-rt* then I can see it getting hotter. Same 
if I run the NVidia driver[*].

At on my limited test on fc21 + bumblebee + binary driver I get suspend 
working again! (which would be very good to have, I miss it). I'll see 
how I migrate to this eventually...

-- Fernando

[*] it can get to be "too hot", if I get there I can't reboot into 
3.14.* successfully, that is, I reboot but eventually the machine hangs 
- apparently there some interrupt the hardware sends probably saying 
something like "hot hot hot" and does it so frequently the kernel just 
gets stuck processing those (you will see a kworker thread using 100% of 
the cpu before the system grinds to a halt). You can either wait till it 
cools down or boot a much older kernel which apparently is not affected, 
3.14.9 in my case, then wait some and boot 3.14.* > 9. This was not fun 
the first time it happened, just before a concert performance on a very 
hot day, outdoor concert and the laptop was the realtime processing 
machine for one piece... ouch...

>> I followed the ritual and the magic incantation is included in
>> grub.cfg but when I look at the boot command /proc/cmdline I don't
>> see these options used. So I'm not sure what is going on. I'm also
>> not sure that linux is using the nvidia graphics (there is also an
>> intel chip in there). I'm trying to figure out how do I even know
>> which card is being used at the moment. Anyway it was worth a try, I
>> guess. Many thanks. Oded
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list