[PlanetCCRMA] Fedora 20 64-bit 3.12.5.-302.rt7.1

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Sat Jan 18 10:16:58 PST 2014

On 01/17/2014 01:56 PM, Don Estabrook wrote:
> Hello -

Hi Don,

> Anyone out there have any experience with the latest CCRMA RT kernel on
> Fedora 20 ?  ie,
>      3.12.5.-302.rt7.1.fc20.ccrma.x86_64+rt
> installed with
>      planetccrma-core-2013.12.19-1.fc20.ccrma.x86_64
> On my HP Elitebook 8540w (Intel i7 @ 2.67 GHz, 8 GiB RAM, nouveau nVidia
> driver), it works fine - I tested quickly with jack and Ardour, using
> the internal Intel HD sound card - but the computer freezes when I try
> to suspend, requiring a hard power-off to reboot.

I have not tried to suspend that kernel, I'll try on Monday on my test 
laptop. Anything left in the logs from the failed suspend?

>  I'm able to suspend
> and resume fine with the stock F20 kernel.
> Not sure it's relevant, but it also throws kernel warnings with
> backtraces during boot-up, like these (from journalctl)
>> kernel: WARNING: CPU: 2 PID: 858 at kernel/sched/core.c:2428 migrate_disable+0xed/0x100()
>> kernel: WARNING: CPU: 2 PID: 858 at kernel/sched/core.c:2462 migrate_enable+0x17b/0x200()
>> kernel: WARNING: CPU: 3 PID: 865 at kernel/sched/core.c:2428 migrate_disable+0xed/0x100()
> some of which say the kernel is tainted (flags G W), while others say it
> isn't.  I don't seem to see those issues when I look at previous boots
> using the stock kernel.
> I'd be happy to provide details, but first wanted to see if these are
> known issues...

Not this one. It would probably be good to post the details in the 
linux-rt-users at vger.kernel.org mailing list.

There is a newer 3.12.x rt patch but I have not been able to boot a 
machine with that one yet. It is a known issue and there seems to be a 
workaround in some posts I read but I have not tried to build a new 
version yet.

-- Fernando

More information about the PlanetCCRMA mailing list