[PlanetCCRMA] rt kernel problems

Bengt Månsson bengt.mansson at gmail.com
Mon Apr 8 11:08:20 PDT 2013

Thanks for quick response. This is clearly beyond my understanding so I am
very grateful for your support.

I have tried again a few times with the rt kernel with threadirqs and a few
times with the non-rt kernel with and without threadirqs.
I start qjackctl and jack. No problem. I start qsynth. Big problem if
threadirqs on. Same place with both kernels. Same problem.
(standard kernel without threadirqs; no problem except xruns..)

Well, this was not easy to capture. There are no BUG or OOPS from dmesg or
in /var/log/messages.
But I managed to catch it another way; I used "tail -f /var/log/messages"
in a terminal window and started qjackctl and jack. Nothing. Started
qsynth. Everything frozen for a few seconds (10?) and then I see a print in
the terminal window (not saved in the file):
ata1.00: exception Emask 0x0 SAct 0x3 SErr 0x0 action 0x6 frozen
ata1.00: failed command: READ FPDMA QUEUED
ata1.00: cmd 60/00:00:20:6a:3e/01:00:00:00:00/40 tag 0 ncq 131072 in
             res 40/00:00:00:4f:c2/00:00:00:00:00/00 Emask 0x4 (timeout)
ata1.00: status: { DRDY }
ata1.00: cmd 60/00:08:20:6b:3e/01:00:00:00:00/40 tag 1 ncq 131072 in
             res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata1.00: status: { DRDY }
ata1: hard resetting link
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300
That's all. One time I saw a little more that looked related to file
system. I could see the word journal but when I tried to scroll the window
Maybe more is coming but fails to print, and nothing ends up in the log
file (second time my phone camera been useful). To me it looks as the
kernel have some panic and write-lock the disk quickly. (If someone guide
me I could maybe setup another linux box to catch syslog via network. If
it's worth the effort..)

See inline below for some other details.

So. Should I take my HW to the junk yard or do you have better advice?


2013/4/6 Fernando Lopez-Lezcano <nando at ccrma.stanford.edu>

> On 04/06/2013 12:01 PM, Bengt Månsson wrote:
>> Hi folks,
>> Again I have to call out for some advice.
>> Here is what I've done:
>> - Installed fresh from f18 xfce live dvd (simple partitioning with ext4)
>> - Installed repos for ccrma and rpmfusion
>> - updated everything except kernel (which is now 3.6.10)
>> (when I tried that in one go it didn't work at all. I started fresh
>> again and updated in pieces; first everything except kernel and xorg,
>> then xorg).
>> - removed pulsaudio
> (I have not found a need to do that...)

Before I saw emails from people with problems, but it's good news if they
are now solved by default. Been away too long so I'm not updated.

>  - added a /etc/modprobe.d/local.conf to fix the ordering of sound devices
> (It is usually best to refer to the card by name instead of number and
> then the ordering does not matter - ie: use hw:NAME instead of hw:0, you
> can find the name between [] in the output of "cat /proc/asound/cards").

I know about that but jackctl doesn't seem to know. It seems to remember
the number so everytime I have to check and sometimes change. So I followed
your advice about Multiple sound cards workaround ;)

Is there any better way than using qjackctl? I find that I almost always
have to use it to get the connections right.

>  - used realTimeConfigQuickScan and follow advice
>> - run alsamixer to set the volumes
>> - otherwise I think I kept everything default
>> With this system, I can start (in order) qjackctl, jackd, qsynth and
>> rosegarden.
>> I can play some simple stored music. With a processor load of 5%
>> (according to qjackctl) I can get a latency around 10 ms without
>> problems with xrun (just).
> Did you try starting the kernel with the "threadirqs" boot option? And
> running rtirq with that? It is supposed to give you better latency
> performance (that option was part of the rt patch and has since migrated to
> the mainline kernel).

> What soundcard do you have?

The main one is an M-Audio Audiophile 2496 on PCI.
(Then there is one on the motherboard, which I have disabled in BIOS,
and another on the EVGA GeForce 210 PCIe graphics card for hdmi output.
Later on, when I connect the piano I will get MIDI and yet another
soundcard on USB. Otherwise I have keyboard and mouse on USB.)

>  Not impressed. I would like to run more stuff with less latency, so I
>> try to install the rt kernel (3.8.4) and rtirq.
>> This configuration starts, but it's completely useless. I start qjackctl
>> and jackd and it looks ok. I start qsynth and try to start rosegarden.
>> The latter never starts and the machine start to behave very strange in
>> many ways. Windows can be moved but the app inside is not responding.
>> Windows turning white. When i try commands in the terminal some can work
>> but other say "Input/output error" or "read-only file system". Only way
>> to restart is power-off the hard way.
> Ah, that all points to a really really bad problem, most likely you are
> managing to trigger some internal kernel bug. Do you see anything at that
> point in the output of "dmesg" or in /var/log/messages? Something like a
> BUG or OOPS followed by a dump of the internal state? If that is the case
> we should report that to the rt kernel developers...

 I have started again with the stock 3.6.10 kernel and the machine is
>> working again, but without the performance I would like to see.
> You could also try to update the non-rt kernel from Fedora, I think the
> current one is up to 3.8.x as well. I don't use it so I don't know if that
> will improve performance...

Changed to that one. No significant difference I can notice.

> -- Fernando
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20130408/6bfde7aa/attachment.html 

More information about the PlanetCCRMA mailing list