[PlanetCCRMA] rt-kernel and firewire

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Fri May 4 10:28:05 PDT 2012

On 05/04/2012 02:15 AM, barb wrote:
>> I added a file called "99-firewire.rules" to /etc/udev/rules.d with the
>> following contents:
>> KERNEL=="fw*", MODE="0660",OWNER="root",GROUP="jackuser"
>> Obviously you would need to be a member of the "jackuser" group for it
>> to work.
> i had that before. just for testing tried it and still the same problem.
> as user no, as root yes.
> mistake:
> Start: Cannot create realtime thread (1: Operation not permitted)

Install the package planetccrma-rt-permissions, that will enable the 
proper maximum rt priority you can use as a user (if you are included in 
the jackuser group). Or planetccrma-rt-permissions-all to give access to 
all users (less secure). The default for Fedora is too low for the 
Planet CCRMA rt patched kernels (a fix is in the works in Fedora).

-- Fernando

> i agree it should be a permissions problem, but i tried all kind of
> permissions on /dev/fw* by now.
> b#

More information about the PlanetCCRMA mailing list