[PlanetCCRMA] sced missing from Gedit plugins

Jeff Sandys jpsandys at gmail.com
Sat Jun 30 10:40:10 PDT 2012

> On 06/28/2012 06:35 AM, Schindler, Allan wrote:
>> ... I have lost sced functionality
>> in gedit for editing/running SuperCollider. The sced plugin no
>> longer appears in gedit's Preferences->Plugins list.
>> SuperCollider runs fine with emacs (I get sound out).
>> Packages supercollider, supercollider-gedit, supercollider-world (all
>> version  3.4.5 release 1.fc16.ccrma) are installed.
>> supercollider.lang file exists in /usr/share/gtksourceview-2.0/language-specs.
>> supercollider.xml exists in /usr/share/mime/packages.
>> The sced directory and  the sced.gedit-plugin file both exist in /usr/lib/gedit-2/plugins
>> In desperation I also tried copying these into ~/.local/share/gedit/plugins.
>> One other anomoly, although probably unrelated: when opening Gedit, I get the
>> Gtk error message
>>   Failed to load module "pk-gtk-module"
>> although a yum check reveals:
>> Package PackageKit-gtk-module-0.6.22-2.fc16.i686 already installed and latest version
> I don't think you have missed anything, I think supercollider 3.4.x does
> not support Gedit3 (which is what fc16 has). You would have to upgrade
> to supercollider 3.5.x - that one is available from the planetccrma
> testing repository in fc16 (install planetccrma-repo-testing to access
> that) - I'm not 100% sure the upgrade will be fully automatic, you may
> have to remove some package manually as the names and contents of
> packages shifted (long story). Let me know how it goes.
> -- Fernando

I have fedora 16 x86_64 on my laptop, sced didn't work at first,
but it does now.  I'm not sure what I did to fix it, but last week I
tried it, thinking that I might be able to get time off from work
to attend the Supercollider class at CCRMA (sadly, not).

I have Supercollider 3.5.2 and gedit 3.2.6
The supercollider.plugin and supercollider.py are in the
usr/lib64/gedit/plugins folder, and PackageKit-gtk3-module is
installed.  I see that there is both a gedit and gedit-2 folder,
maybe this is the issue.

If you have any questions about my configuration that might
help you solve the problem ask me directly or on the list.
Even though I have used emacs for a long time, supercollider
with gedit is my preference.

-- Jeff

More information about the PlanetCCRMA mailing list