[PlanetCCRMA] sced missing from Gedit plugins

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Fri Jul 13 17:42:23 PDT 2012

On 07/13/2012 02:30 PM, Schindler, Allan wrote:
> I am *still* trying to get supercollider functional with gedit/sced
> (gedit-3.2.6-1.fc16.i686) on F16 and am still getting compile errors.

Argh, very sorry to hear that (I was hoping you were up and running 

> The errors I get from sced are:
> init_OSC
> empty
> compiling class library...
> NumPrimitives = 665
> compiling dir: '/usr/share/SuperCollider/SCClassLibrary'
> compiling dir: '/usr/share/SuperCollider/Extensions'
> pass 1 done
> at
> '/usr/share/SuperCollider/Extensions/MathLib/classes/Solver/Solver.sc'
> line 52 char 56
> code -54
> in file
> '/usr/share/SuperCollider/Extensions/MathLib/classes/Solver/Solver.sc'
> line 52 char 56
> ERROR: Parse error
> in file
> '/usr/share/SuperCollider/Extensions/MathLib/classes/Solver/Solver.sc'
> line 52 char 56:
> ^
> ++ [{ arg... args; af.(*args) }];

Hmmm, I'm looking at the file with "more" and see a weird character in 
that line.
This is what it looks like in an emacs buffer:

			order = (af.def.numArgs-1);
			f = ((order-1).collect{ |i| { arg... args; args[i+2]\312} })
				++ [{ arg... args; af.(*args) }];
			f = f.as(NFunc);

The "\312" is a character that probably should not be there. There is 
another line like that somewhere below:

			f = af.collect{ |func,k|
				//postln("function: "++ k);
				(((order-1).collect{ |i| { arg... args; args[i+2+(k*order)]\312} })
				++ [{ arg... args; func.(*args) }])

I'm trying to imagine _why_ this is triggering an error for you (I have 
those same files and they work). Maybe you are working with a different 
locale and in that one that character is recognized and acted upon??

I tried to actually edit the file and emacs said:

These default coding systems were tried to encode text
in the buffer `Solver.sc':
   (emacs-mule-unix (15 . 4194187) (1516 . 4194250) (1880 . 4194250))
   (utf-8-unix (15 . 4194187) (1516 . 4194250) (1880 . 4194250))
However, each of them encountered characters it couldn't encode:
   emacs-mule-unix cannot encode these:
   utf-8-unix cannot encode these:

Click on a character (or switch to this window by `C-x o'
and select the characters by RET) to jump to the place it appears,
where `C-u C-x =' will give information about it.

So there is something fishy going on with those characters (and there's 
one more I had not seen!)

I'm attaching an edited version of that file, could you login as root 
and replace the one that is there with this one? Sorry, I'm running out 
of things to try :-(

The full path of the file should be:

Let us know how it goes...
-- Fernando
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Solver.sc
Type: application/vnd.ibm.secure-container
Size: 3591 bytes
Desc: not available
Url : http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20120713/bc51c3b1/attachment-0001.bin 

More information about the PlanetCCRMA mailing list