[PlanetCCRMA] pulseaudio successfully banished to the AC97 CODEC?

Craig Bourne cbourne at cbourne.com
Tue Apr 26 14:15:57 PDT 2011

To whatever degree my own recent experience may parallel this case-- I 
too am using Fedora 14. Throughout all the problems that I have had with 
ALSA/Pulseaudio,  Chrome has continued to work. This was true even 
though a proper configuration was not specified to Pulseaudio for my RME 
HDSP 9652 card (the only sound card in my system).

This in itself would seem to suggest that Chrome enjoys a degree of 
independence at least from Pulseaudio.


On 04/26/11 13:38, Julius Smith wrote:
> Thanks for the extra info.  I see that Chrome uses various plugins to
> handle "audio streams", so I guess it depends on how the plugin works,
> and there are several of them (VLC, Totem, Windows Media Player, ...).
> My main observation so far, however, is that configuring my preferred
> JACK audio interface to 'off' in the PulseAudio Volume Control seemed
> to solve my contention problem.  I'll post an update if I run into any
> more trouble along these lines.
> - Julius
> On Tue, Apr 26, 2011 at 9:34 AM, Fernando Lopez-Lezcano
> <nando at ccrma.stanford.edu>  wrote:
>> On 04/25/2011 10:04 PM, Julius Smith wrote:
>>> I should have said "the first server wins and the second server
>>> loses".  The race for me was typically Chrome vs. JACK. - jos
>> I imagine that Chrome is trying to use alsa directly and not through
>> pulseaudio. In that case all bets are off. Maybe there is a confguration
>> option in Chrome? If you start Jack you should see it asking for the card
>> and getting it from pulseaudio.
>> -- Fernando
>>> At 09:59 PM 4/25/2011, Julius Smith wrote:
>>>> Yes, I'm using Fedora 14.  I have never seen PA relinquish
>>>> anything.  My experience is that the first device wins and the
>>>> second device loses.  Could I have some old configuration stuff
>>>> somewhere?
>>>> At 09:31 PM 4/25/2011, Fernando Lopez-Lezcano wrote:
>>>>> On 04/25/2011 08:53 PM, Julius Smith wrote:
>>>>>> I just discovered an apparently valuable utility with the humble name
>>>>>> "Volume Control" at
>>>>>>       Applications / Sound&     Video / PulseAudio Volume Control
>>>>>> There is a Configuration tab where it appears possible to disable
>>>>>> devices by setting them to "off".  I disabled everything but the AC97
>>>>>> CODEC (the little audio chip on the motherboard), and now it appears
>>>>>> pulseaudio is happily using that while JACK uses the EDIROL UA-25EX
>>>>>> (hooked up via USB).
>>>>>> PA/JACK coexistence is peaceful for the time being.  Before, I had to
>>>>>> be careful to start JACK before something like Chrome that used
>>>>>> pulseaudio.
>>>>> Is this on Fedora 14? When JACK starts PA should relinquish the
>>>>> card (and of course nothing will come out of Chrome audio - I have
>>>>> not tried Chrome myself). What error messages were you getting?
>>>>> Perhaps Chrome is not using PA for audio? (in that case all bets are
>>>>> off).

More information about the PlanetCCRMA mailing list