[PlanetCCRMA] Installing Google Voice Chat for Linux on Fedora instead of Debian

Niels Mayer nielsmayer at gmail.com
Tue Sep 7 11:21:31 PDT 2010

On Tue, Sep 7, 2010 at 10:57 AM, Niels Mayer <nielsmayer at gmail.com> wrote:
> FYI if you're running without pulseaudio (so as to avoid the problems
> it introduces -- see two messages below as examples), the
> GoogleTalkPlugin has an annoying delay every time it tries to access
> an audio device, as it's querying for pulseaudio and not finding it
> present and timing out. Each time this happens, you'll see a message
>     "socket(): Address family not supported by protocol"

Ugh... I thought I had solved this, as I wasn't seeing the messages
when testing my change. But I just had a phone call and saw the
pulseaudio message again, even with my --disable-sound hack. I also
tried  giving the command-line arg directly to the google plugin and
it won't accept this gnome argument (even though the browser does). SO
I'm not sure what I was seeing the first time, and sorry for reporting
on false success.

Is there an environment variable that does the same thing as
--disable-sound so that pulseaudio never gets called within a Gnome
app? Some KDE apps like 'kmix' have a special envvar for this:

Any equivalent envvar in the underlying gnome libraries to disable
pulse and go straight to ALSA?


More information about the PlanetCCRMA mailing list