[PlanetCCRMA] Nvidia Driver with fc12 Testing Kernel

stuff stuff at johnadon.com
Sun Jun 20 12:03:19 PDT 2010

Worked! Thanks!

2010-06-20 12:40, stuff skrev:
> Thanks! Will try this this afternoon.
> 2010-06-20 11:11, S C Rigler skrev:
>> I found this patch somewhere in the Nvidia forums.  You'll need to
>> extract the driver (use the "-x" switch) in order to apply it. Cd to the
>> top level of the driver directory and do patch -p1<  nvidia_33_rt.patch.
>> It will probably ask you which file to apply the patch to. If you're
>> installing the latest version of the driver then apply it to
>> kernel/nv-linux.h. I believe older versions of the driver will need the
>> patch applied to usr/src/nv/nv-linux.h.
>> --Steve
>> On Sat, 19 Jun 2010 23:46:12 -0500, stuff<stuff at johnadon.com>  wrote:
>>> Hello, All-
>>> I've been unable to compile the kernel module for my NVIDIA graphics
>>> adapter against the kernel in the testing repo
>>> (2.6.33-1.rt7.1.fc12.ccrma.x86_64.rt). It appears to fail when the
>>> nvidia nv.c looks for "next" in one of the kernel source files.
>>> NV_Linux_State-t has no member named "next". The kernel module compiles
>>> fine with any other kernel I've tried.
>>> I've been wanting to try the testing kernel for quite awhile because I
>>> have numerous ardour crashes (especially after recording and then
>>> ctl-scrolling) and kernel errors, as well, although those don't really
>>> seem to relate to jack/ardour/etc since they just happen randomly. I'd
>>> like to see if the issue might be fixed in the testing repo version, but
>>> I can't currently compile the proprietary nvidia kernel module against
>>> the testing repo source. I've tried just about everything else, e.g.
>>> checking keybinding conflicts with window manager, etc., to correct the
>>> ardour crashes without success, even when in a stripped down fluxbox
>>> environment. The kernel errors don't really appear to have any effect on
>>> anything I do anywhere so I'm considering them benign. I'm more
>>> interested in fixing the problems in ardour. Losing a recorded region
>>> shortly after recording is quite an annoyance to say the least. :-)
>>> Does anyone have any hints or tips? Am I trying to do something that's
>>> specifically denied in the source for the nvidia driver or testing
>>> kernel?
>>> Thanks for any info!
>>> John
>>> _______________________________________________
>>> PlanetCCRMA mailing list
>>> PlanetCCRMA at ccrma.stanford.edu
>>> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list