[PlanetCCRMA] firewire-jack-pd

Raphael Raccuia rafael.raccuia at blindekinder.com
Thu Feb 18 06:34:02 PST 2010

I also use Pd with FFADO (edirol FA-101), with no problem...
Two things:

1. did you started Pd with real time option? I had dio errors just like 
you, and this solved the problem.
$ pd -rt  #if you use midi, add -alsamidi to get ports clients in jack 
alsa tab automatically

2. I  noticed that Pd become really unstable with very low latency (>128 
@ 48000)

hope this helps...

Oded Ben-Tal a écrit :
> I'm somewhat baffled by the behaviour I'm getting from my system recently. 
> I'm developing a Pd patch for a somewhat complicated setting which means 
> the patch is getting complex.
> The strange thing is that it seems to be running ok when I'm using an old 
> USB soundcard using the oss emulation layer (pd -oss)
> but when I'm trying it on a new firewire card with jack(*) I'm getting a 
> lot of A/D/A sync errors with audible clicks.
> I tried changing the buffer size in qjackctl from 64 to 512 and also 
> trying 3/4 frames nothing seem to work (except make things impossibly 
> worse at 64)
> Any suggestions?
> thanks
> Oded
> (*) firewire card == SaffireLE with 6 outputs. usb card == Quattro. Since 
> I'll need the 6 outputs eventually I really hope to get it working.
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list