[PlanetCCRMA] which Fedora?

Bernardo Barros bernardobarros2 at gmail.com
Fri Dec 3 18:52:46 PST 2010

That's great, lots of packages already!

I still get the same problem with pd-extended. But I can use the
extensions from pd (vanilla). Not a problem for me personally, since I
don't use it much nowadays. I would suggest to include pd-python,
pd-lua and pd-wiimote, since there are also nice ones. :-)

Maybe it is a difference between how fedora and debian handle folder
names, like "lib" and "lib64"? Just a guess.

2010/12/3 Fernando Lopez-Lezcano <nando at ccrma.stanford.edu>:
> On 12/02/2010 09:31 PM, Fernando Lopez-Lezcano wrote:
>> On 12/02/2010 10:45 AM, Fernando Lopez-Lezcano wrote:
>>> On 12/01/2010 04:15 PM, Bernardo Barros wrote:
>>>> Maybe I didi something wrong but I get:
>>>> sh: /usr/bin/pd-gui: No such file or directory
>>> Thanks for testing and the feedback!
>>> Hmmm, pd is not looking in the right place, apparently. I'll have to
>>> look at this to see what is going on. pd-gui is actually being installed
>>> in /usr/lib64/pd-extended/bin/, try adding that to the path temporarily
>>> to see if the problem is fixed.
>> This is something that is not working in the 64 bit version. I just
>> tested at home in my old laptop and the new pd for i386 starts and does
>> not complain.
>> I'm pretty sure something in pd-extended is looking in /usr/lib instead
>> of /usr/lib64... (I fixed some of this stuff).
> I pushed a new build of pd-extended for x86_64, there was indeed a hardwired
> assumption in pd's source about the location of things, /lib/ instead of
> /lib64/ for x86_64. Anyway, while pd might find pd-gui I saw a bunch of
> other places where this happens as well. Let me know how it goes.
> (there are other packages in the repo now...)
> -- Fernando
>>>> 2010/12/1 Bernardo Barros<bernardobarros2 at gmail.com>:
>>>>> 2010/11/30 Fernando Lopez-Lezcano<nando at ccrma.stanford.edu>:
>>>>>> Just today I released supercollider (same version as before, 3.4.1
>>>>>> is not
>>>>>> yet out) and also pd extended 0.42.5 with an x86_64 build, all for
>>>>>> Fedora
>>>>>> 14. More to come...
>>>>>> Not tested on x86_64 at all but I presume it - of course - will
>>>>>> work fine
>>>>>> :-)
>>>>> Really Nice! For me sc worked well, but not pd-extended. I'm on x86_64.

More information about the PlanetCCRMA mailing list