[PlanetCCRMA] Fedora rt kernels and ffado

John Lyon jalyon1009 at gmail.com
Fri Apr 23 13:42:11 PDT 2010


I've spent a couple of days trying to sort out my problem, so far with no
luck.  I hope one or more of you has the answer.  I've looked through the
PlanetCCRMA mailing list archive, and I see clues, but not enough
information for me to go on.  Here is my problem.

I have a focusrite Saffire Pro 26 IO firewire interface. I was using the
PlanetCCRMA distro with Fedora Core 10, and an updated linux kernel 2.6.29
(can't remember the rest, but it was from the planetccrma testing
repository.  ffado, jack, and ardour all worked well enough, with a few
glitches and lockups and xruns, etc.  But it was useable.  I spent some time
trying to get the focusrite midi interface working, without success.  So I
tried upgrading to the Fedora 12 distro, with planetccrma.  Nothing worked,
and I couldn't get the my nvidia video card working under the new realtime
kernel (2.6.31).  ffado wouldn't load and the ffado diagnostic software said
that I had the new firewire stack built into the kernel and that ffado
2.0.0.x didn't work with that stack.  Okay, now what?   I thought I'd get
brave and try the beta of Fedora 13.  I had heard that the new 2.6.33 kernel
might work better.  But now I find out there is no realtime kernel that new
(unless I try to compile it myself with the realtime patch).  And ffado
still gives me the same message (I'm using the stock Fedora 13 kernel,
without the realtime patches).  I had heard that the new kernels are pretty
fast and that maybe I wouldn't need the realtime patch. I tried downloading
the latest ffado versions, even the SVN development package, but on the
stock Fedora kernels, it complains about the in-kernel firewire stack being
incompatible with ffado (but it doesn't offer any help as to how I might
remove the firewire stack from the kernel. I've read about blacklisting
stuff in 'modprobe.conf' but am not sure if that would help).

I'm in a dilemma, and don't quite know what to do.  I COULD go back to
Fedora 10 and use the 2.6.29 realtime kernel, and try to figure out how to
get midi working. The nvidia video driver compiles on that kernel (I haven't
figured out how to make it compile on the newer realtime kernels (there have
been some changes in the kernel and the nvidia driver needs patches to make
it compile and run with the 2.6.31 kernels).

I could also reload Fedora 12 and try again with the Planetccrma realtime
kernels.  I just thought it would be interesting to try Fedora 13 and see if
the newer 2.6.33 kernels might work better with ffado and jack.

Or I could revert back to the (now unsupported) Fedora 10 and Planetccrma.
Then there is Fedora 11 and Planetccrma... Oy!

Here's what I'd LIKE to do:  find a step-by-step set of instructions for
getting ffado to work on the newer realtime kernels (yes, I've looked at the
ffado web site and sent a message to their mailing list but so far no
response).  I believe that involves getting a kernel with the new in-kernel
firewire stack removed.

One thing I haven't tried yet is installing one of the Fedora 12 realtime
kernels on Fedora 13 just to see if it makes ffado any happier.  I'll try
that next and report back on the outcome.  Failing that, I'll try
re-installing Fedora 12, then try Fedora 11, than revert back to Fedora 10,
which worked well enough once I installed realtime kernel 2.6.29x.

I apologize if I'm missing something technical here; I've worked with Linux
since 1994, and have spent a lot of time in the past learning how to make
stuff work (by googling and reading and studying and asking questions).
Lately, however, I've been just wanting to make music, and not fight with
the technology.  So I've been reluctant to go through the rigamarole of
getting up to speed technically to the point where I can recompile the
kernel if necessary (for example) to solve a problem. I just want to get
back to recording!

Any suggestions and/or advice would be much appreciated.   I need to move on
this pretty quickly as I have customers who want to record some music, and
right now I have a broken system.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20100423/1a2b1c30/attachment-0001.html 

More information about the PlanetCCRMA mailing list