[PlanetCCRMA] planetccrma-apps missing in F11 repo

David Cornette david at davidcornette.com
Sat Sep 26 01:03:43 PDT 2009

I just checked http://sourceforge.net/projects/freqtweak/ , and apparently
there was a new version released this past July.  Looking through the changes
to the source, it looks like the file configure.ac was modified to use
wxGTK2.6. And this thread http://fedoraforum.org/forum/showthread.php?t=119907
indicates that the official Fedora package of wxGTK2.6 include xrc.  So it
would probably be easiest to package Freqtweak-0.7.2, and forget about trying
to get the old version to work.

On Sat, Sep 26, 2009 at 12:46:16AM +0000, Fernando Lopez-Lezcano wrote:
> On Wed, 2009-09-23 at 02:46 -0400, David Cornette wrote:
> > Freqtweak fails because it needs compat-wxGTK24-2-devel and
> > compat-wxGTK24-2-xrc.  Fedora 11 has compat-wxGTK26-devel, which might (or
> > might not) do to replace compat-wxGTK24-2-devel.  There does not appear to be
> > a replacement for compat-wxGTK24-2-xrc.
> There is not. I had to build my own for fc10. I'm retrying the build now
> on fc11, I don't remember but I presume it failed when I first tried. 
> ...
> Hmm, just finished. So it must be something in freqtweak itself (bet it
> is some header thing). 
> ...
> I get an error when including one of the wxGTK24 headers... there's
> something the compiler does not like about /usr/include/wx/string.h.
> > Finally, I tried building cm.  There were several issues with this one.
> Indeed. 
> > First, it needed to have the versions of various other programs specified for
> > Fedora 11.  I am not sure that I got them all right (I don't really understand
> > the purpose of the "orig" versions)  Next, there was a change in sbcl that a
> > one line change, for which I have a patch that seems to have worked.  After,
> > that, I found that the packaging of portmidi had changed, so the build
> > requirement should now be on portmidi-devel rather than on portmidi.  But then
> > I ran into what would seem to be an sbcl bug.  Here is the message:
> > 
> > ; compiling file "/home/makerpm/rpmbuild/BUILD/cm/fomus/backend_xml.lisp" (written 22 AUG 2007 06:49:27 PM):
> > 
> > debugger invoked on a SB-INT:BUG in thread #<THREAD "initial thread" RUNNING {10028E8011}>:
> >     failed AVER:
> >   This is probably a bug in SBCL itself. (Alternatively, SBCL might have been
> >   corrupted by bad user code, e.g. by an undefined Lisp operation like
> >   (FMAKUNBOUND 'COMPILE), or by stray pointers from alien code or from unsafe
> >   Lisp code; or there might be a bug in the OS or hardware that SBCL is running
> >   on.) If it seems to be a bug in SBCL itself, the maintainers would like to
> >   know about it. Bug reports are welcome on the SBCL mailing lists, which you
> >   can find at <http://sbcl.sourceforge.net/>.
> I run into this as well (not long ago, in the latest rebuild for fc10). 
> Could not find a way out... I think at this point the correct thing to
> do would be to migrate to the latest cm releases but I anticipate much
> pain, if previous experiences are a guide :-)
> It is puzzling, the fomus used in the latest cm is numerically older
> than what is being used in that very very old snapshot. 
> Well, most probably the whole Planet CCRMA lisp world needs a rework to
> use s7 for everything (cm/clm/cmn), s7 is the latest scheme interpreter
> by Bill. 
> -- Fernando

More information about the PlanetCCRMA mailing list