[PlanetCCRMA] FC11 emacs unknown option -sclang

Felix Pfeifer pfeifer.felix at googlemail.com
Thu Sep 10 03:19:53 PDT 2009

Hi Anders,

i put your file to /usr/share/emacs/site-lisp/
but it still doesn't work. Here is the output
from emacs' message window:
Loading /usr/share/emacs/site-lisp/site-start.d/focus-init.el (source)...done
Loading /usr/share/emacs/site-lisp/site-start.d/php-mode-init.el (source)...done
Loading /usr/share/emacs/site-lisp/site-start.d/po-mode-init.el (source)...done
Loading /usr/share/emacs/site-lisp/site-start.d/rpm-spec-mode-init.el
Loading /usr/share/emacs/site-lisp/site-start.d/w3m-init.el (source)...done
Source file `/usr/share/emacs/site-lisp/sclang-interp.el' newer than
byte-compiled file
Loading /home/felix/.viper...done
For information about GNU Emacs and the GNU system, type C-h C-a.
command-line-1: Unknown option `-sclang'


2009/9/9  <andersvi at notam02.no>:
>>>>>> "F" == Felix Pfeifer <pfeifer.felix at googlemail.com> writes:
>    F> Hi all, i recently switched to FC11 and now tried to start emacs
>    F> with -sclang option.  But: i have to start sclang with Meta-x
>    F> sclang-start, because emacs doesn't know this option
>    F> anymore. Some1 knows why?
> Im not sure where this crept in, but it hasnt worked for some time,
> possibly because of changes with emacs v.23.
> Recent emacsen seem to expect the switches to include the hyphen, ie:
>    (add-to-list 'command-switch-alist (cons "-sclang" . (lambda ()...)
> Heres a version of sclang-interp.el with these switches updated:
> Ill see if i can put in a test on version in sclang-interp.el and commit
> a change later today.
> -anders

More information about the PlanetCCRMA mailing list