[PlanetCCRMA] Hydrogen on F10 crashes desktop when starting.

Nigel Henry cave.dnb2m97pp at aliceadsl.fr
Fri Mar 27 11:18:35 PDT 2009

RESOLVED. See below.

On Thursday 26 March 2009 23:58, Nigel Henry wrote:
> Anyone having problems with Hydrogen on F10?
> Each time I try to start it from the desktop icon, it opens the splash for
> hydrogen, and the info window. the splash goes away, but when I click on OK
> on the info window for hydrogen, it immediately crashes the KDE, or Gnome
> desktop, bringing me back to the GDM login.
> Today I installed VLC, and after trying that with a DVD, I tried Hydrogen
> again, and for the first time I got Hydrogen to open. Played a few demo's,
> then closed it. Then opened Hydrogen again, but it's gone back to crashing
> the desktop as before.
> Anyone else seeing this behaviour? If so, any possible fixes.
> Hydrogen version is 0.9.3 from the rpmfusion repo
> Amd64 processor, but all distros installed are 32bit (i386)
> Pulseaudio is disabled with an: apt get remove alsa-plugins-pulseaudio
> Just also tried ssh'ing into F10 from my FC2 install, and running Hydrogen
> from FC2, and it works ok. perhaps it's a graphics problem on the F10
> install, but other GUI audio apps, ZynAddSubFX, MhWaveedit, Sonic
> Visualiser, etc, work without problems.
> Any hints as to why Hydrogen is always crashing the desktop on F10 (apart
> from one occasion) would be welcome.
> Nigel.

After a serious ssh session from FC2, I now have Hydrogen starting ok on F10.

It appeared to be a problem with the "Auto" setting for audio output, and 
perhaps that setting may have worked ok if I'd left pulseaudio enabled, but I 
disabled pulseaudio for resolving a problem with something else.

Running F10's Hydrogen via ssh on FC2, I first changed "Auto" to "Alsa", and 
Hydrogen still played ok, but loads of clicks on the sound, and loads of 
xruns showing on FC2's Konsole. I didn't try Hydrogen on F10, as the sound 
was awfull. Next I changed "Alsa" to Jack", and closed Hydrogen. Opened 
Qjackctl on F10, and started jackd. Then re-opened F10's Hydrogen on FC2, and 
played a demo. No xruns at all, and perfect sound, even with the horrible hda 
intel card on the F10 machine. Closed Hydrogen on FC2, and tried re-opening 
it on the F10 machine, and Hydrogen opens with no problems, and sound is fine 
using the "Jack" setting for audio out. Problem resolved.

I also had a problem with VLC producing no sound, and that was after having 
disabled pulseaudio. VLC also has an "Auto" setting for audio out, but when I 
changed that to "Alsa", I had sound on VLC when playing DVD's.

Other audio apps, ZynAddSubFX (Jack), MhWaveedit (Alsa), Phasex (Alsa), 
SonicVisualiser (Alsa, used to be only Jack IIRC) have no problems on F10 
with pulseaudio disabled, but none of these apps have "Auto" for selecting 
audio output.

The reason I disabled pulseaudio is that I set a one liner in rc.local to play 
a tune (John Sebastien's "Summer in the City) using aplay , which plays ok on 
bootup, before GDM opens, and on into the opening of the KDE desktop, and 
beyond, until the tune finishes. With pulseaudio enabled, when the tune 
finishes, there is no sound available unless I logout, and backin.

With pulseaudio disabled, and the same tune being started from rc.local, there 
are no problems. the tune finishes sometime after the KDE desktop is opened, 
and the sounds are still working.

Perhaps the above stuff will be of some help to folks with similar problems, 
when pulseaudio is disabled on F10.


More information about the PlanetCCRMA mailing list