[PlanetCCRMA] Pulse and ice 1712

Jan Depner eviltwin69 at cableone.net
Wed Jul 1 12:18:06 PDT 2009

Alright, I have beaten the internet to death trying to find out
something about this.  Here is the problem - I have an ST Audio DSP 2000
C-Port (ice 1712 chipset).  It worked just fine under Fedora 8.  I have
loaded both Fedora 10 and Fedora 11 and the card produces tons of noise
unless I set it to 96K in envy24control.  Of course that makes most
stuff sound like Alvin and the Chipmunks.  I have now loaded the rt
kernel and the rtPAE kernel.  That doesn't change anything at all.  I've
loaded CentOS and had no problems.  I get no output from Pulse at all.
I have killed pulseaudio by doing pulseaudio -k and still no change.  If
I try aplay -vv after I kill pulse it shows:

Playing WAVE 'new.wav' : Unsigned 8 bit, Rate 44100 Hz, Mono
ALSA <-> PulseAudio PCM I/O Plugin
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : U8
  subformat    : STD
  channels     : 1
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 8
  buffer_size  : 22050
  period_size  : 5512
  period_time  : 125000
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 5512
  period_event : 0
  start_threshold  : 22050
  stop_threshold   : 22050
  silence_threshold: 0
  silence_size : 0
  boundary     : 1445068800
##################+                                | 35%^C

No sound output.  If I run alsamicer I just get the one pulseaudio
fader.  Can anyone tell me how to completely remove pulse from the
equation?  Also, what would be the best way to try to debug this?  I've
spent a couple of weeks on this already.  I'd really like to get it
resolved.  Any help would be greatly appreciated.


More information about the PlanetCCRMA mailing list