[PlanetCCRMA] getting midi to work?

Oded Ben-Tal oded at ccrma.Stanford.EDU
Sat Jan 10 08:15:59 PST 2009

I'm hoping to just play a midi file using pmidi on fc10 and failing. 
don't normally use midi so I'm completely clueless at this point.
I have an external midi keyboard hooked through a quattro card.
pmidi -l returns two ports
14:0     Midi Through                      Midi Through Port-0
  16:0     USB Audio Quattro                 USB Audio Quattro MIDI 1

but neither seem to work (no sound).
the man pages for pmidi state that it needs snd-seq-midi to work. That 
used to be define in /etc/modprobe.conf but not any longer.
having gotten nowhere with pmidi I tried qtractor + jack
qtractor doesn't appear on the midi tab of jackctl  (only the audio tab) 
from within qtractor the output setup shows both midi ports but won't let 
me connect qtractor to usb quattro.
Am I missing something basic or is there some problem with quattro's midi?

(I also tried to test midi in/out in pd but didn't get anything to work)

Oded Ben-Tal
oded at ccrma.stanford.edu

More information about the PlanetCCRMA mailing list