[PlanetCCRMA] Saffire Pro 10 not working on CCRMA/F10 [Solved]

Linux Media linuxmedia4 at netscape.net
Sat Feb 28 21:32:13 PST 2009

>>>> Great... Solved!!!
>>>> Pieter Palmers at the ffado list (one of the ffado Developer) helped me 
>>>> understand the ffado-mixer.
>>>> ...
>>>> Would you mind if I post a "step by step" for setting up a Forcusrite 
>>>> Saffire Pro 10 on CCRMA/Fedora10? Or would that be too OT?

>>> Completely on-topic... it would be great!
>>> -- Fernando

>> I see that the raw1394 module doesn't load at bootup or when the
>> interface is plugged in. Do I put that in /etc/modprobe.conf to have it
>> load at bootup?
>> I don't have a /etc/modprobe.conf, but if it goes there, do I just
>> create it and put...
>> raw1394
>> ...in the file, and nothing else?

> Hmmm, I don't really know what is required...
> This is probably a side effect of Fedora dropping the old firewire
> stack. 
> You could try adding (to /etc/modprobe.conf):
> alias char-major-171 raw1394
> At least in my laptop running fc9 that alias is not part of what
> '/sbin/modprobe -c' shows. But most probably something would be required
> in the udev rules configuration to create the /dev/raw1394 device?

Yeah, I don't know how all that works. The main thing is that the 
raw1394 module can be loaded manually and that I know all the steps to 
getting the Pro 10 working and running. I'm in the process of learning 
all the parts of the ffado-mixer that relate to the Pro 10 and then I 
will add that into the "step by step" guide.


More information about the PlanetCCRMA mailing list