[PlanetCCRMA] rtPAE with nvidia?

Tracey Hytry shakti at bayarea.net
Wed Apr 15 15:20:28 PDT 2009


Maybe Fernando should have said that the newest 29s weren't tested with the nvidia drivers.  When I did the testing on my end it was done without any proprietary drivers, so that any bugs could be sent to the real time developers.

On my 64 bit machine with the SLI graphics I also need the nvidia drivers because "X" is still unstable on the machine while running fedora9.  After the testing of the new rt-kernel I also tried to build the nvidia driver via the rpm-fusion method.  I also got the the "kernel sources can't be found" error and then tried to install the kernel-headers;  which told me that the headers clashed with files from another package  (libdrm-devel-2.4.0-0.13.fc9.x86_64).

I'd really like to look into this, but don't have a lot of time right now.  I was thinking of dumping the whole source tree for the kernel( somewhere, point the akmod system at it, and try to build the nvidia driver that way.  Has anyone tried it?  I know I could download all of the driver stuff from nvidia and try the get it running that way;  but I also know that nvidia's packages overwrite quite a of number of files and it isn't easy getting the system back to working properly afterwards.

Anyway, this whole process is going to take some time.  If anyone has tried various ways to build the drivers could you please post how you tried?  Maybe with enough information and enough searching we can figure out how to get the nvidia drivers running with the newest kernel.

More information about the PlanetCCRMA mailing list