[PlanetCCRMA] Problem running audio through jack

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Wed Jun 4 14:02:19 PDT 2008

On Wed, 2008-06-04 at 20:53 +0000, Reyort, Nav wrote:
> Hello Fernando,
> Yes, the sound card on my computer is hda-intel.
> When I tried 3 periods instead of 2, I hear clean sine tone from audio output now.
> I tried running the command
> jackd -R -d alsa -d hw -n 3
> And terminal returned me following messages:
> -----------------------
> jackd 0.109.2
> Copyright 2001-2005 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
> JACK compiled with System V SHM support.
> loading driver ..
> SSE2 detected
> creating alsa driver ... hw|hw|1024|3|48000|0|0|nomon|swmeter|-|32bit
> configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 3 periods
> ALSA: final selected sample format for capture: 32bit little-endian
> ALSA: use 3 periods for capture
> ALSA: final selected sample format for playback: 32bit little-endian
> ALSA: use 3 periods for playback
> -------------------------
> Does this mean jack is working properly?

If you don't see anything else then yes, it should be working. 
For hda-intel, 3 periods is the key. 

> Is there anywhere I can find document about jack so I can learn 
> what all the parameters and set up work?

There is documentation in www.jackaudio.org, or in a terminal to "man
jackd" to get the man page for jackd...

-- Fernando

More information about the PlanetCCRMA mailing list