[PlanetCCRMA] Re: freebob broken today

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Tue Feb 19 12:21:01 2008

On Tue, 2008-02-19 at 20:30 +0100, Arnaud Gomes-do-Vale wrote:
> Fernando Lopez-Lezcano <nando@ccrma.Stanford.EDU> writes:
> > On Tue, 2008-02-19 at 11:56 -0500, Hector Centeno wrote:
> >> OK, it seems that the problem is the new Jack from the CCRMA testing
> >> repository. I installed it last night and tested it without rebooting
> >> and worked fine but today after rebooting it didn't work with freebob
> >> (alsa is ok). I reinstalled the stable version, tested right away and
> >> didn't work, rebooted and retested then it worked! Does this make
> >> sense? 
> >
> > Not really. Very strange as I would imagine that a reboot would not
> > help, unless this has something to do with kernel modules. But how? I'll
> > see if I can take a look at this in more detail. 
> ISTR rebooting after upgrading was needed to free some shared memory
> area or IPC resource or something, at least for some svn versions of
> jack, not sure if it still applies to 0.109.x. Paul Davis told me
> about this a while back, but I can't find any relevant info on
> jackaudio.org.

Yes, you are right, that could be it (the reason why the reboot is
needed). I'm sure the jackd data structures in shared memory have
changed. There is some arcane command I don't remember that can be used
to free up the shared memory...

-- Fernando