[PlanetCCRMA] Kernel breaks software suspend in fc6

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Sep 4 13:25:02 2007

On Mon, 2007-09-03 at 09:52 +0200, hmk@algonet.se wrote:
> Hi all,
> First thanks to Fernando for a great work in maintaining the CCRMA 
> software!


> Now, the other day I installed the latest CCRMA kernel
> 1.fc6.ccrmart on a Dell Optiplex GX270 that I have here. All seems to 
> be well when the box is booted up, but software suspend doesn't work 
> anymore. It worked flawlessly with the CCRMA kernel 2.6.21-0182.rt21.3.
> fc6.ccrmart and the Fedora standard kernel, as well as 
> several earlier kernels.
> Symptoms are that when suspend is invoked from the kde logout menu, 
> the monitor goes into standby / powersave mode, but the computer hangs 
> (disks, fans, power-led etc. are still on). No reaction to mouse or 
> keyboard. The only way to recover is to power-cycle or hold the power 
> button pressed for several seconds to shut down forcefully, then 
> restart. On the next boot messages about ext3-recovery are present in 
> dmesg, which indicates that the shutdown was unclean.

I can confirm that it is not working either in fc7 (in my laptop). The
suspend process hangs in "Stopping tasks..." and the computer has to be
turned off to leave that state. 

I have never worked with suspend so I don't know where to start to debug
this. It must be an interaction with the realtime kernel patch. 

> Please tell me what to look for if more information is needed! Below I 
> attach a dmesg from the fedora standard kernel (to show what hardware I 
> have etc.) and then I could give a dmesg for the
> ccrmart in another post.

I'm building new versions of the fc6/7 kernels that have as many patches
from the stock Fedora kernel applied as possible. From a preliminary
test it does not seem to make any difference with regards to suspend

-- Fernando