[PlanetCCRMA] [Planet CCRMA] : Jack and Freebob issues on Fc8

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Fri Nov 23 10:56:01 2007

On Fri, 2007-11-23 at 15:57 +0100, Mysth-R wrote:
> Hi, I recently update my system to fc8. I still have some config to do
> (wifi, nvidia graphic card,...) but it works pretty well.
> Yesaterday I tried to do some music with pd, and Zynaddsubfx through
> I got a Firebox Presonus Firewire sound Card. So I run Jack using
> Qjackctl with : 
> jackd -R -P65 -t2000 -dfreebob -r48000 -p512 -n3 -D
> I got some difficulties to establish the real issue. Jack run
> perfectly. Then I run pd and zynadd, create my connection, and then
> while I am making the connection, Jack Stops, and sometimes doesn't
> respond anymore so I can't see the error message from Qjackctl. 
> Ok while I was writting this message, I tried again. 
> Run qjackctl : 
> jackd -R -P65 -t2000 -dfreebob -r48000 -p512 -n3 -D
> running pd with : pd -rt -jack -alsamidi
> Here is the message :
> 15:41:21.293 Patchbay deactivated.
> 15:41:21.389 Statistics reset.
> 15:41:21.447 Startup script...
> 15:41:21.447 artsshell -q terminate
> JACK tmpdir identified as [/dev/shm]
> JACK tmpdir identified as [/dev/shm]
> 15:41:21.514 ALSA connection graph change.
> sound server terminated
> 15:41:21.888 Startup script terminated successfully.
> 15:41:21.888 JACK is starting...
> 15:41:21.889 /usr/bin/jackd -R -P65 -t2000 -dfreebob -r48000 -p512 -n2
> -D
> 15:41:21.891 JACK was started with PID=4948.
> jackd 0.103.0
> Copyright 2001-2005 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
> JACK compiled with System V SHM support.
> loading driver ..
> SSE2 detected
> Freebob using Firewire port 0, node -1
> 15:41:22.092 ALSA connection change.
> 15:41:22.310 ALSA connection graph change.
> 15:41:22.993 ALSA connection graph change.
> libiec61883 warning: Established connection on channel 0.
> You may need to manually set the channel on the receiving node.
> libiec61883 warning: Established connection on channel 1.
> You may need to manually set the channel on the transmitting node.
> 15:41:23.094 ALSA connection change.
> 15:41:24.102 Server configuration saved to "/home/mysthr2/.jackdrc".
> 15:41:24.103 Statistics reset.
> 15:41:24.890 Client activated.
> 15:41:24.893 JACK connection change.
> 15:41:24.896 JACK connection graph change.
> JACK tmpdir identified as [/dev/shm]
> SSE2 detected
> 15:44:09.981 ALSA connection graph change.
> 15:44:09.985 JACK connection graph change.
> 15:44:10.073 JACK connection change.
> 15:44:10.074 ALSA connection change.
> 15:44:13.023 Shutdown notification.
> 15:44:13.026 JACK is stopping...
> 15:44:13.029 JACK is being forced...
> zombified - calling shutdown handler
> 15:44:13.031 ALSA connection graph change.
> 15:44:13.229 JACK was stopped successfully.
> 15:44:43.229 Post-shutdown script...
> 15:44:43.229 killall jackd
> QProcess: Destroyed while process is still running.
> 15:44:43.231 ALSA connection graph change.
> 15:44:43.232 ALSA connection graph change.
> 15:44:44.047 Post-shutdown script terminated successfully.

Hmmm, it looks like one of the clients is timing out and bringing down
the server. Or it could be the firewire stack I guess. What happens if
you use a non-firewire card? Do you have one?

> Yesterday, I finally test different config from qjackctl, and I tried
> to disable the realtime option. Then It was working "perfectly", but I
> heard many crackles not XRUNS, but crackles in sound. 

That sounds like xruns. 

> I think these were produced by Pd since I ran it with no -rt option. 
> So Is there a problem with my RT configuration ? I don't know where I
> can look for to solve my issue. 

Does jack eventually die if you run it for a while without clients? I
would also try with a different soundcard (not firewire). 

> Just another thing, I can't remember if it was doing the same on fc7,
> but when qjackctl is running in RT mode the read-out "RT" near the DSP
> load percent and the sample rate, winks. Is it normal ? 

I think that is normal. 

Was this all working fine on fc7? It could be a problem with the new
-- Fernando