[PlanetCCRMA] Re: the Planet starts to land on Fedora 8

Alexander Smith alex.smith.ixium+xithium at googlemail.com
Wed Nov 14 01:33:00 2007

On Tue, 13 Nov 2007 18:08:42 -0800, Fernando Lopez-Lezcano wrote:

> Hi all... I first cut at the core components of Planet CCRMA for i386
> (lightly tested) and x86_64 (not tested). For risk takers only :-)
> [you can always keep making music using Fedora 7, right?]
> Instructions in the website here:
> http://ccrma.stanford.edu/planetccrma/software/installplaneteight.html
> So far:
> - kernel-rt based on plus Ingo's rt11 (and most of the current
> Fedora patches). Ancient firewire stack instead of juju. - libraw1394
> un'jujued
> - rtirq
> - alsa-tools
> - alsa-firmware
> - souped up jack-audio-connection-kit
> More details in the release notes at the end of the install section.
> I'll start with the applications build marathon tomorrow. Enjoy!
> -- Fernando

I decided to be adventurous and tried out your new kernel on my F8 x86_64 
system :p
The kernel boots OK, but once the system's started, the GUI has slowed 
down to an almost unusable rate. When I tried to start JACK in realtime I 
get this error message:
'cannot use real-time scheduling (FIFO at priority 10) [for thread 
-754224400, from thread -754224400] (1: Operation not permitted)'

Interestingly, when I tried to copy and paste the error message, QJackCtl 
produced this:
'QClipboard::setData: Cannot set X11 selection owner for PRIMARY'
'QClipboard::setData: Cannot set X11 selection owner for CLIPBOARD'

FWIW, the Fedora 7 rt kernel on the same architecture didn't have these 
problems on my machine - in fact it performed really rather well! :)