[PlanetCCRMA] no supported simd instruction sets

Jonathan Segel jsegel@magneticmotorworks.com
Thu May 3 10:43:01 2007

On May 1, 2007, at 5:29 PM, Fernando Lopez-Lezcano wrote:

> On Tue, 2007-05-01 at 16:32 -0700, jonathan segel wrote:
>> On May 1, 2007, at 3:55 PM, Fernando Lopez-Lezcano wrote:
>>> On Mon, 2007-04-30 at 17:47 -0700, Jonathan Segel wrote:
>>>> On Apr 30, 2007, at 4:54 PM, Fernando Lopez-Lezcano wrote:
>>>>>> On Mon, 2007-04-30 at 16:42 -0700, jonathan wrote:
>>>>>> i was having  a problem with freqtweak, but now i'm realizing  
>>>>>> that
>>>>>> the problem is much bigger.
>>>>>> this is in fc6, on a pentium III sharp laptop, i've been bouncing
>>>>>> installs back and forth between the two large drive partitions,
>>>>>> presently one is fc6 and one is fc5.
>>>>>> fc5 is fine.
>>>>>> booting jack in fc6, i get the "No supported SIMD instruction  
>>>>>> sets
>>>>>> detected" in the message box of qjackctl.
>>>>> Could you copy the output of "jackd -d alsa -d hw" into an email?
>>>>> (and
>>>>> "rpm -q -i jack-audio-connection-kit"?) This is probably  
>>>>> related to
>>>>> another bug/feature someone else found when trying to use a Duron
>>>>> processor. When there's no SIMD instructions it should just use  
>>>>> the
>>>>> normal copy/add functions.
>>>> hmm. it isn't finding hardware now, only the modem is listed in the
>>>> qjackctl  hardware availability...
>>> Yes, there's something else wrong in your setup. I exhumed a very  
>>> old
>>> machine from our hardware graveyard (PIII based) and went through  
>>> the
>>> "install fc6 and jack" there. It is apparently working fine.
>>> The "No supported SIMD instruction sets detected" is normal, it  
>>> means
>>> the CPU does not have sse2, 3dnow, etc and jack cannot use the  
>>> vector
>>> based assembler speedup routines for copying or adding buffers
>>> together.
>>> But it does work normally after that, at least in my machine.
> I may add this was with the regular Fedora kernel. At this point I am
> not building a regular i586 kernel on Planet CCRMA for fc6. Was  
> this on
> fc5 or fc6? Which kernel? ("uname -r" to know).

this is only fc6. fc5 works, has always worked. (as did fc1,3,4)

>> i see. doing a little research i discovered sort of the same things,
>> reading about people doing video stuff with pIII machines.
>> well, what's weird is that supercollider is saying the same thing
>> when i try to boot a server, it shows up for a second in qjackctl
>> then dies.
> Are you using emacs?

yes. been using SC scel/scum for several years, i actually don't use  
the planet SC package because i'm so used to cehcking it out and  
compiling it myself on both this machine and my os x machine.

>> if i boot in a regular non-rt non-planet kernel, my regular hardware
>> shows up at least, the intel 810 set. same problem with SC though.
> Yes, I just tried sc and it does not boot on a piii machine (after I
> changed the selinux preference to allow text relocations), this is  
> with
> the regular Fedora kernel but the Planet CCRMA pam installed to get
> realtime priority access by default. I would not be surprised if it
> requires sse2 or something that a piii can't provide.

as in,  some new things in SC needs sse2 now, or only in fc6? like i  
mentioned, i have been using this old laptop for some time for this  
stuff and it all works in <=fc5. shall i ask the SC list?

>> anyway. is there a relatively easy way (command wise) to reinstall
>> the entire fc6 and keep my home directory? or reinstall the entire
>> thing and not keep /home and then just copy what i need from
>> elsewhere...?
> Hmmm, too many questions at once :-)

well, then let me ask this. is there any easy way to use yum to  
replace all packages at once? perhaps my install is not right in the  

> I'm testing this stuff in a dual 600MHz PIII with 256M of ram (an HP
> Kayak) and it is already swapping with only a few programs running.
> Linux has become bloated with age :-)
> -- Fernando

curse of the overreaching programmer! well. we expect it.
thanks for all help!
Jonathan Segel                 4014 Brookdale Ave. Oakland, CA 94619
jsegel-magneticmotorworks.com <-----> magsatellite-yahoo.com