[PlanetCCRMA] CAPS plugins (denormals) causing xruns on Ardour

Beepo / Vanguard beepo@vanguard.fi
Sat Mar 10 17:41:03 2007


I tried this only briefly and only with few combinations of CFLAG
values. I'll try to do more testing as soon as possible.

I removed the precompiled version of caps plugins, retrieved the source
for caps-0.3.0 and tried following version of CFLAGS with them setting
the OPTS variable in the MakeFile:

OPTS = -O6 -ffast-math -funroll-loops -Wall -fPIC -DPIC -msse2 

2nd (including the suggestions in the MakeFile):
OPTS = -O6 -ffast-math -funroll-loops -Wall -fPIC -DPIC -msse2
-mfpmath=sse -pipe -ftracer -m3dnow

Both versions still had the same symptoms xrunning after a transport
stop in ardour when I tried with 'AmpIV - Tube amb emulation + tone

I'm using AMD Athlon64 3000+ processor. Below is the contents
of /proc/cpuinfo

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 12
model name      : AMD Athlon(tm) 64 Processor 3000+
stepping        : 0
cpu MHz         : 2002.619
cache size      : 512 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm
3dnowext 3dnow up
bogomips        : 4008.25
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp


On Sat, 2007-03-10 at 16:36 -0800, Anthony Green wrote:
> On Sat, 2007-03-10 at 16:03 +0200, Beepo / Vanguard wrote:
> > It seems that I might pinpointed the problem of the XRuns. I did my
> > homework by reading through the net and it seems the XRuns could be
> > caused by a known problem with very small floating point processing
> > inside the some ladspa plugins. So this is not necessarily a Ardour
> > problem. At least the XRuns went away when I removed the CAPS: AmpIV -
> > Tube amb emulation. Some other plugins are working ok.
> What kind of processor are you using?
> I'm wondering if the problem would go away if the floating point
> operations in the CAPS plugins used SSE hardware instead of the 387.  It
> would be helpful if you could rebuild CAPS with gcc's -msse2 and see if
> that makes a difference.  If so, I'd like to put a little effort into
> building and distributing multiple versions of these ladspa plugins.
> Thanks,
> AG
> > More information about this issue I found from address:
> > 
> > http://www.ardour.org/node/139
> > 
> > Sorry to been bothering you...