[PlanetCCRMA] Planet CCRMA x86_64 and Adour/Ardour2 XRuns

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Fri Mar 9 15:39:01 2007

On Fri, 2007-03-09 at 23:22 +0200, Beepo / Vanguard wrote:
> Hi,
> Forgive me writing such a long version, but it includes the whole path
> of the upgrade. The actual questions can be found at the very end of
> this message ;) Anyway thanks again for all that have been there for me
> earlier and especially for Fernando for the hard work.
> I've just installed the x86_64 version of Planet CCRMA on a fresh FC6
> installation. I knew I would be taking a bit of a risk since I had
> perfectly working 32bit version on FC5 but the temptation was too big.
> The installation was almost a walk in the park. I did a completelly
> fresh install of FC6 and updated it with yum before the Planet CCRMA
> installation. Only thing that I had to do when installing the
> planetccrma-core package was to force the pam to install. For that I
> downloaded the CCRMA pam package and installed it manually by issuing
> command: rpm -Uhv --force pam-

Hmmm, why was it not installing? "--force" is _always_ a bad idea, it
means there's something wrong with the package database. Do you remember
what the error was? (I don't have an x86_64 machine to test this on). 

-- Fernando

> After that the installation process continued smoothly. The real
> problems started however this morning. I had left the computer on over
> the night. At the morning the autofs service was taking up to the 50% of
> processor power for some reason so I stopped the service. Problem was
> gone ;)
> Then I started experimenting with the Ardour2. There was some hickups to
> get the jack starting. For some mystical reason the integrated sound
> card of my motherboard was enabled. I remember that I had this kind of
> issues with FC3 or 4 even if the card is completelly disabled in BIOS.
> FC5 32bit version worked fine without any trouble.
> When the Jack was up and running I played around with Ardour2. Ardour
> 0.99 projects could not open with Ardour2 that just crashed. So I tried
> with new project. For some reason it was not able to record anything at
> first. The signal showed up in the mixer when the track was armed but
> nothing was actually recorded.
> For some mystical reason the recording started to work after Ardour
> restart so I was able to continue testing. After one audio track I set
> the Jack sync on and started Hydrogen. After that started the flow of
> xruns whenever I stopped the playback in Ardour2.
> Problem is that the same thing happens with the Ardour 0.99 (+ it has
> some UI problems. The markers bar above the tracks is shifted to the
> right some bars)
> I noticed that even the processor was completelly idling the load of the
> system was between 1.2 - 1.6. I suspected the nvidia drivers (I use the
> beta version from NVidias site) and I had copied the old FC5 xorg.conf
> directly to the FC6 installation. So I configured the X again using
> nvidia-xconfig. That solved the problem and the loads went down to 0.2
> when idling (don't know exactly why).
> After that I still have the xrun problem whenever Ardour/Ardour2
> playback is stopped. The recording / pplaying back works perfectly but
> as soon as I stop the transport the XRuns get the world. XRuns stop when
> I exit the ardour.
> The questions in breaf:
> -----------------------
> Is there a way to tell the Alsa that it should not know anything about
> the integrated audio card and the only sound card in the system should
> be the SB Audigy EX? (I have allready commented out the modules in the
> modprobe.conf and unloaded the modules manually. For some reason the
> modules are loaded always)
> Could the XRun problem go away by fixing the above one?
> Regarding the bristol Fernando mantioned in earlier messages I get a
> flash of the UI and then the following:
> initialising one arp2600
> parent exiting
> done create interface: 764100, 76c6f0
> Client ID = 131
> Queue ID = 1
> Registering 0 1
> Registered 131 0
> opened GUI midi handle: 1, fd 46
> Read Configuration: arp2600
> return - no data in buffer
> exit algo: 1, 7d6910, 0
> removing one arp2600
> /usr/share/bristol/bin/startBristol: line 302: 10990 Segmentation fault
> $BRISTOL/bin/brighton $* -engine
> My system is:
> FC6 x86_64 with Planet CCRMA (kernel 2.6.20-0119.rt8.fc6.ccrmart)
> Asus K8V SE Deluxe
> AMD Athlon64 3000+
> Memory: 1024MB
> Sound Blaster Audigy EX
> 25Gb IDE boot disk
> 2xSATA150 120GB disk as a software RAID for projects
> Best Regards:
>   Aapo Romu
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma