[PlanetCCRMA] fc6/7: new rt kernel; fc6/7: updated libgig

grae drunkenbird@gmail.com
Fri Jul 6 01:00:02 2007

Hi Fernando,  weird times is right!  A UFO must have been flying over
my house messing with my bits! :P

I am impatient and curious, ;) so I tried to back out the installation
of the new kernel and from there on things just started to look
strange.  Trying to remove the 1394 libs resulted in ~70 ccrma apps
being uninstalled and by the end of it, yum was telling me that
gnome-applets* had a dependency on the 1394 libs.  The first part I
could maybe understand, but once gnome-applet became tied to firewire,
well things were starting to smell fishy ;) (but what do I
know...maybe it's right???)

So I turned off the computer and did some other stuff and came back,
read your post here (from my mac), and decided to fire it back up and
reapply the new kernel, 1394s and qjackctl as I did numerous times to
no avail, except of course this time it worked....what do ya know???

Unfortunately though that isn't even my real problem, I really do live
in interesting times because apparently the laptop that I am trying to
run ccrma off of (dell inspiron 630m) has a nasty bug with the
internal firewire port and the dvd drive.  Anyone experiencing
problems with their firewire port on a dell laptop might want to check
this forum post:


Essentially everything works excellent and then out of the blue jack
zombifies (although sometimes it dies right away).  For the longest
time I thought it was due to irq sharing (maybe it still is), but then
I stumbled upon that post tonight.  All the people there were using
windows, so the symptoms weren't exact but being a seemingly low level
issue I suspect I'm lucky enough to share in their pain! ;)  (Actually
a number of them were receiving new drives from Dell).  Anyway, so I
was just in the process of trying to test this theory out by disabling
the dvd in the laptop (do you know how in linux? noprobe boot
command?) when I decided to update the kernel and everything went
kaput.  haha...so maybe it wasn't a ufo, maybe it's a sign!  Stop
messing around with your crappy Dell laptop!

I'm on a deadline as I'm currently working on producing my own first
album and I'm really behind schedule.  So I think what I'll do now is
forget about the laptop (I'm still interested in disabling the dvd to
test it :)  ), get some work done on the mac and in between things
I'll get fedora 7 up and going in a dual boot on the mac and say
goodbye to that crappy laptop forever. :)

I better go to bed..it's late. :)  Thanks for looking into it and
sorry that it just "resolved itself".  I honestly don't know what was
going on.  It was really strange.


the rpm -V didn't have any output for either package.

Oh, little update...so the package stuff resolved but I'm getting
zombified on every startup now.  No error message, just
"zombified-calling shutdown handler".  I'll get fedora up on the mac.
This laptop has taken too much of my time.


On 7/6/07, Fernando Lopez-Lezcano <nando@ccrma.stanford.edu> wrote:
> On Thu, 2007-07-05 at 22:27 -0700, Fernando Lopez-Lezcano wrote:
> > On Thu, 2007-07-05 at 21:26 -0500, grae wrote:
> > > Hi Fernando,
> > >
> > > I had some issues before trying to run firewire on fc7 and they were
> > > resolved by installing a libavc1394 and libraw1394 from
> > > ezplanet-updates repo.
> > >
> > > After installing this new kernel my firewire again does not work with
> > > the same error message as before:
> > >
> > > "Ieee1394Service::initialize: Could not get 1394 handle: No such file
> > > or directory
> > > Is ieee1394 and raw1394 driver loaded?"
> >
> > Hmmm, sorry to hear about this happening again.
> >
> > The new kernel does not have any differences in terms of firewire
> > support, I'm still using the old firewire stack.
> I did the following in my laptop:
> - I am running the new rt19 kernel, of course (i686)
> - rebuilt the libraw1394 and libavc1394 libraries in my build server
> - installed them
> - /sbin/modprobe raw1394
> - installed kino from livna
> - plugged in my dv camera
> - started kino and it was able to recognize the camera and record
> I don't know if this is good news or bad news :-(
> (because it is not working for you)
> Maybe I should reboot and start from scratch to see if that makes a
> difference.
> Most probably I'll release the new packages tomorrow. But then of course
> the machine becomes incompatible (in terms of firewire) with the stock
> Fedora kernels.
> "May you live in interesting times"[*]
> -- Fernando
> [*] apparently an ancient chinese curse?