[PlanetCCRMA] Newbie question

Henrik Frisk henrik.frisk@mhm.lu.se
Tue Jan 2 05:05:02 2007

Fernando Lopez-Lezcano <nando@ccrma.Stanford.EDU> wrote:

> On Mon, 2007-01-01 at 20:17 +0100, Henrik Frisk wrote:
> > Well, that's what I thought too, but then I saw that the FC5 default
> > kernel had a name containing SMP, but then again, I'm new to Fedora and
> > I'm new to Dual Core so I'm just guessing...
> You should be able to use the smp kernel. AFAIK "dual core" == "dual
> cpu", I'm using Athlon dual cores with no problems. Perhaps the
> confusion is because some earlier dual cores were two chips in a single
> ic, I think all the current ones are two processors in just one chip.
> Hmmm, well, then there was the "hyperthreading" thing with P4
> processors, there was just _one_ processor but apparently two being
> reported. The "second" processor was just make believe using idle cycles
> of the only cpu available. Depending on what you did you could have a 10
> to 20% improvement in speed - but that was definitely a one processor
> hardware setup. 
> Which kernel exactly are you trying to boot (the smp one)? Do happen to
> see anything like an error message? Does the machine simply stop at some
> point in the boot process?
2.6.16-10.2080.16.rdt.rhfc5.ccrmasmp but I tried the PREEMPT-RT kernel
    too with the same result. The boot process simply stops at (last
    line of output).

ide0: ports already in use, skipping probe

I doesn't throw any errors as far as I can see. The output up until the
point above is identical compared to the boot process with the single
CPU kernel.