[PlanetCCRMA] I had time for a quick test

Tracey Hytry shakti@bayarea.net
Tue Jan 2 04:20:02 2007

Err, make that a quick test and a long clean up.

I thought that it would be a good idea to try let the machine run doing a latency/xrun test while I was working outside.  Not a good idea, didn't even make it outside until I cleaned up the mess.

I tried Ingo's newest(29th) kernels on both fc5 and fc6(i686 for fc5 and x86_64 for fc6).  I modified rtirq and adjusted rtlimits to work with the the new kernels and jack on fc6.

My first try was on fc5.  It booted fine, rtirq did it's job, and went into X fine.  I got jack running, conservative settings, and began by loading up hydrogen.  I was going to load up aeolus too, so I was playing with the setup to load load hydrogen... AND... total freeze up... motherboard speaker putting out a continuous beeeep.

So I hit the reset button on the computer and decide to try fc6.

Loaded up fc6, booted ok, though I had to use the alsasound script to tickle fc6 into loading the sequencer modules.  In fc6 I got a little further, got hydrogen loaded and running, got aeolus loaded.  But then while trying to use qjackctl to get midi input from an external keyboard I started to run into troubles.  Besides not being able to get the midi info to pass to the soft synth, I ran into a (not as hard) lock up of the apps on the screen.  I was able to kill close aeolus, had to use a gnome widget thing to kill hydrogen(it locked itself in it's little window).  But then, I noticed that both jackd was running in the background and qjackctl was zombied.  I tried to kill them off, but even a kill -9 from root wouldn't get rid of them.  So I ended up leaving xwindows and with some difficulty rebooting the machine.  This is all a bit hard to remember, it happened about 8-12 hours ago and it's late(should be in bed).

I went back to fc5, booted into a ccrma kernel and it hung on boot with error messages.  I then tried a stock fc5 kernel and still wouldn't boot.  From the text on the screen, it was having trouble accessing the /var partition.  So I booted into fc6 and learned from the man pages how to fix a slightly broken xfs file system on the /var partition of fc5.  BTW, I also have a rescue partition on that machine to boot from if both fc5 and fc6 had gotten hosed so I wasn't too afraid(at least until I noticed I had screwed up a xfs partition).

I remember on an Ingo kernel from about week or two ago that I didn't get lockups like this on the machine.  It's hard to say what was happening, but I was just happy to get the machine working again after that.  I then decided maybe dinner would be better, and then work outside.  If I feel brave in the next few days I may try again, but it was a bit scary there for a while, as the fc5 is what I'm using right now and is my main machine/distro.

Tracey,  pushing computers to the edge, saying whoops as I nudged them too far toward the edge, and putting the pieces back together again.