[PlanetCCRMA] Package does not match intended download (planetccrma-core on F7)

Wade Nelson hollywoodb@fastmail.fm
Fri Aug 3 14:47:02 2007

On Fri, 03 Aug 2007 09:57:55 -0700, "Fernando Lopez-Lezcano"
<nando@ccrma.Stanford.EDU> said:
> On Fri, 2007-08-03 at 01:32 -0500, Wade Nelson wrote:
> > The thing that strikes me as odd is that I can consistently fail those
> > two packages with the exact same MD5 sum bail-out.  I live in a rural
> > area and happen to know my ISP very well, and there is no caching
> > involved.  In fact, the error posted has been consistent now for about
> > 10 days, and just now I posted to the ML since between myself and my ISP
> > I had determined that nothing on our end should be acting up.  In the
> > example posted I ran a `wget` on the packages (which reported they were
> > already downloaded, because they were) and got the *exact* same cpio MD5
> > bail-out.  I've subsequently rm'd the RPMs and `wget`'d them again with
> > the exact same MD5 bail-out.  It just strikes me as very very odd.
> Very strange that you are getting the _same_ md5 problem! That is really
> weird. I don't know how to debug this. If I do a wget locally (I have to
> try this from home as well) I get a correct download and can install the
> exact same kernel. 
> Hmmmm, I do have a machine that sometimes will do something similar. I
> think it is some kind of sporadic motherboard problem related perhaps to
> the network interface - when yum-installing a very large package
> (~530Mbytes) I would sometimes get a cpio error when yum tries to
> install it. _Copying_ it manually from an nfs mount and then using rpm
> would succeed. Very strange. Maybe related to the problem you are
> having? (I know, I know, very very unlikely that hardware is the
> problem...). 
> Do you have another machine you could use to download the package?
> -- Fernando

I downloaded the packages my laptop and copied them to the target
machine via scp and got a different MD5/cpio error.  I then tried to
install kernel-rt on my laptop and got the same MD5/cpio error I got on
the target machine, so I don't think there was any corruption in the scp
copy.  I also downloaded them manually on the target machine via wget
and appended a "?noproxy" to the end (I don't know if that makes a
difference) and got again a different MD5/cpio error.

However it is just the kernel-rt and alsa-firmware packages, so far I
haven't had this issue with any others.  Strange indeed.

Wade Nelson