[PlanetCCRMA] Experiences with new kernel + FC4 & FC5

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon May 15 17:07:01 2006

On Mon, 2006-05-15 at 15:18 -0700, John Wimbere wrote:
> Hello,
> I just finished trying to install the new kernels with
> FC5 and FC4 and I wanted to relay my experiences.
> My system is based on the MSI KT6V motherboard (VIA
> KT600 chipset) with an Athlon 2800+, Seagate SATA 80
> GIG hard drive, 2G RAM, and an Echo Gina 3G soundcard.
> First, before installing FC5 I was running FC4 with
> the 2.6.10-0.4.rdt kernel and this was working very
> well. I was getting 1.45ms latency at 44.1khz with
> minimal xruns.
> I did a fresh install of FC5 and first tried the new
> rrt kernel.  I noticed higher latency (5.8) with a
> significant number of xruns. 

Yuck, sorry to hear that. It runs fine here but I have not done real
exhaustive testing. Not much I can actually do, it is about the latest
kernel with the latest patches coming directly from Ingo. 

> The rdt kernel, as
> suggested, performed less attractively.  At least with
> the new ALSA packages my Gina 3G was configured and
> Echomixer was fully functional.
> I then reinstalled FC4 and tried the new rrt kernel
> again--same increase in latency and xruns.  But this
> time my Gina 3G was undetected and no Echomixer.  

That is strange. Do you have the kernel-module-alsa package that matches
your kernel installed? The kernel proper does not have the echo drivers
yet, they have not been merged into the kernel tree. For that you have
to install the extra kernel-module-alsa package (should come in
automatically if you use the planetccrma-core-* meta packages). 

Thinking of that, you did install that in fc5, right? Other goodies like
the rtirq script that reorders priorities of interrupts come are
required by the meta package. Check that that is there are enabled:
  rpm -q rtirq
  /etc/rc.d/init.d/rtirq status

> I am aware that others have mentioned the performance
> shortcomings of VIA chipsets, but because FC4 with the
> 2.6.10-0.4.rdt kernel was working so well, I was a bit
> surprised to witness the results of the new installs. 
> If anyone has any feedback or suggestions, I certainly
> am willing to give it another go.
> In the meantime, is the 2.6.10-0.4.rdt kernel still
> available for installation?

Let's see:
# apt-get install kernel | grep 0.4.rdt
  kernel-smp#2.6.13-0.4.rdt.rhfc4.ccrma 2.6.13-0.4.rdt.rhfc4.ccrma 
looks like it is still there. 

> I understand all this is a work in progress, and many
> thanks for all the work done past and present.  I wish
> I could do more than relay my install results.

I guess it would be great to try to track where the bug latency hit is
coming from. I'd have to do a bit of research to remind myself of what
needs to be done. 

-- Fernando