[PlanetCCRMA] Rezound and AMS : unmet dependencies: Solved

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Mar 13 09:21:02 2006

On Mon, 2006-03-13 at 11:18 +0200, Cumhur Erkut wrote:
> Hi and thanks to Nigel and Fernando for suggestions,
> On this machine, I am a user with sudo privileges to install/remove Planet CCRMA packages; our 
> sysadmin administrates the machine otherwise (therefore Fernando's suggestion was easier to try 
> out). My apt sources list reads:
> [cerkut@erase ~]$ cat /etc/apt/sources.list.d/planetccrma.list
> # Planet CCRMA RPM Repository for Fedora Core 4
> rpm http://ccrma.stanford.edu/planetccrma/apt fedora/4/i386 core updates
> rpm http://ccrma.stanford.edu/planetccrma/apt fedora/4/i386 extras ## NOTE THE EXTRAS!!!
> rpm http://ccrma.stanford.edu/planetccrma/apt fedora/4/i386 planetccrma
> rpm http://ccrma.stanford.edu/planetccrma/apt fedora/4/i386 planetcore
>  > What happens if you try to install this:
>  > apt-get install fftw2 fftw
> [cerkut@erase ~]$ sudo apt-get install fftw2 fftw
> Reading Package Lists... Done
> Building Dependency Tree... Done
> E: Couldn't find package fftw2
> I tracked down the dependencies with rpm -q --whatrequires: fftw -> fftw-devel-3.1-3.fc4 -> 
> octave-devel-2.1.72-3.fc4
> then removed octave (temporarily, since I need it)
> [cerkut@erase ~]$ sudo apt-get remove fftw fftw-devel octave-devel
> ...
> The following packages will be REMOVED:
>     fftw (3.1-3.fc4)
>     fftw-devel (3.1-3.fc4)
>     octave (6:2.1.72-3.fc4)
>     octave-devel (6:2.1.72-3.fc4)
>     octave-forge (2006.01.28-2.fc4)
> and installed ams for testing:
> [cerkut@erase ~]$ sudo apt-get install ams
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following extra packages will be installed:
>     clalsadrv (1.0.3-1.rhfc4.ccrma)
>     fftw (2.1.5-8)
> The following NEW packages will be installed:
>     ams (1.8.7-2.rhfc4.ccrma)
>     clalsadrv (1.0.3-1.rhfc4.ccrma)
>     fftw (2.1.5-8)
> fftw (2.1.5-8) comes from Extras repo, but ams installed and worked fine. Briefly checked 
> rezound and planetccrma-audiovideoapps: no more dependency issues. Later, I will ask our 
> sysadmin to disable extras in my planetccrma.list and try to find an octave version compatible 
> with the planet ccrma apps.

I don't think the planteccrma "extras" url in the apt configuration is
the problem. That is an old snapshot. Most probably the newer fftw was
installed (maybe automatically?) through yum, which is most probably
pointing to the full extras repository. 

What happens if you _now_ try to install fftw3 and octave through apt?

To see where things are coming from you can query packages with
apt-cache, for example:
  apt-cache policy fftw3
  apt-cache policy fftw
should print all versions available and from where, there will be a "*"
next to the one that's actually installed. 

-- Fernando